sync_with_child: child died before initialization

I recently bought two Wixel boards and I am trying to program them. I get the following messge when I run make_all.bat in the wixel-sdk folder:

Compiling apps/io_repeater/io_repeater.rel
0 [main] sh 4588 sync_with_child: child 1996(0x108) died before initialization with status code 0x0
167 [main] sh 4588 sync_with_child: *** child state waiting for longjmp
/bin/sh: fork: Resource temporarily unavailable
make: *** [apps/io_repeater/io_repeater.rel] Error 128
You may now close this window.

I checked that make.exe is the one you recommend:

make -v

GNU Make 3.82-pololu2
Built for Windows32
Copyright © 2010 Free Software Foundation, Inc.
Modified by Pololu https://www.pololu.com
License GPLv3+: GNU GPL version 3 or later http://gnu.org/licenses/gpl.html
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

“where make” show me the following:
C:\Pololu\Wixel\GNU Build Utilities\make.exe
C:\winavr\utils\bin\make.exe

My Path env variable looks as follows:
set path=C:\Pololu\Wixel\bin;C:\Pololu\Wixel\GNU Build Utilities;c:…

I searched the forum and found an answer that mention WinAVR. Not sure how winAVR fit in the picture, however, since I have the Pololu make.exe first in the path, I don’t think winave make.exe takes effect. Also, I couldn’t use that answer to resolve my problem.

I am running on Windows Vista 64bit.

I have the following folder structure under c:\pololu\wixel

  • bin
  • drivers
  • examples
  • GNU Build Utilities
  • SDCC
  • wixel-sdk

I am able to run “Wixel configuration utility” and I am able to upload “wxl” files to the board. But I need to be able to write and compile my own.

Your help is sincerely appreciated.

Hello. I have seen this problem before in the context of AVR programming, and I believe it only affects Windows Vista, so you could consider upgrading.

It looks like make.exe is finding a shell (sh.exe) on your PATH, which probably came from WinAVR, and the shell is the thing that is crashing. One relatively easy thing to try would be to remove all folders from the PATH that contain sh.exe.

A better fix is available here:

madwizard.org/electronics/ar … inavrvista

You should be able to replace your msys-1.0.dll with the version from that site and hopefully that will make things work. Please let me know if you continue to have trouble.

–David

Thanks David. Your advice of removing refernces to winavr from the path variable worked like charm.