SVP-1284 not detected


I have an SVP-1284 that I am trying to program and have read the programming with Atmel Studio 6 guide but I am having issues with getting it to connect.

I have installed the drivers bundle found here:

When connecting the SVP through the USB programmer (built in) it shows in device manager with ports under 10 and I have added the STK500 with the correct port. I go to the Device Programming tool and select ATmega1284P ISP and apply. I then try to read the device signature and it comes up with an error.

“Read voltage 0.0V is outside selected device’s operating range: 1.8 V to 5.5 V.”

And then this:

“Unable to enter programming mode. Please verify device selection, interface settings, target power and connections to the target device.”

I read around and found something to change in the config that came in the bundle, so I try that but it errors saying:

“No Pololu USB AVR Programmer was detected. Please verify that the programmer is properly connected and installed (check the Device Manager).”

Why does it not find it if Device manager says it’s there?

Hello. You need to supply external power to the Orangutan SVP before it can be programmed. What power supply are you using? Did you press the power button? Is the blue power LED on?

You do not have a Pololu USB AVR Programmer so its configuration utility will not work for you.


I have a power supply powering it with 12V and 500mA. It was turned on and the blue light was on. I believe it has a programmer already built in as it said on the product page:

Do I need that one instead of the one it came with? Wouldn’t that be a bit silly?

No, since the Orangutan SVP has a built-in programmer you do not need the Pololu USB AVR Programmer (item #1300).

I think your SVP probably has an older version of the firmware. We had to make some changes to support Atmel Studio 6. When did you get the SVP and who did you get it from? You can find instructions for checking your firmware version and updating it in the “Upgrading Firmware” section of the Orangutan SVP User’s Guide.


It was bought within the last month and after checking the firmware I found it to be 1.03 (SB\VID_1FFB&PID_0087&REV_0103&MI_00).

That’s good: it means you have the latest firmware for the Orangutan SVP.

I have some hope that this problem is specific to Atmel Studio. Could you please install WinAVR and then run the following command at a Command Prompt?

avrdude -P COM2 -p m1284p -cavrisp2

That command should read the device signature. Please copy and paste the output from that command and post it here so we can see what the result is.


Installed WinAVR and ran the code however it seemed to fail.

C:\Users\Hansen>avrdude -P COM3 -p m1284p -cavrisp2

avrdude: stk500v2_command(): command failed
avrdude: stk500v2_command(): unknown status 0xc9
avrdude: stk500v2_program_enable(): cannot get connection status
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude done.  Thank you.

It was on and the blue light was too. It reset when the command started running as well.

Is there anything the I need to set or link on the controller itself?

No, you don’t need to set or link anything on the controller besides turning it on.

Were you ever able to program this Orangutan SVP? If not, it should still have the demo program on it. Does it beep and display words on the LCD when you turn it on?

It’s starting to look like something is preventing the SVP’s programmer from properly detecting the battery voltage. To help figure out what is going wrong, could you please try using a multimeter to measure the voltage (with respect to GND) at the spot indicated below?

The SVP should be powered on when you take this measurement (the blue LED should be on). Also, it might take a few tries to get a good contact, depending on what part of the resistor you touch the multimeter probe to. I find that it works best to touch the flat, top part of the resistor rather than the curving surface of the solder.

While you are at it, it would be good to measure VIN and VCC to make sure they are correct.


Yes they were preloaded with the Demo program and no I have not put any other program on it as I believe this would seem to be stopping it. The LCD displays text, LED flash and Buzzer buzzes.

I am a bit of a novice when it comes to measuring but here is what I got.

  • 5V from VCC to GND
  • 10.48V from VIN to GND
  • 3.12V from the Resistor to GND

I hope this helps.

I am working together with Carl , we do have a couple of the orangutan SVP 1284 , and we both got the same problem

Hello, J.P. and Carl.

I am sorry you are both having trouble. How many units do you have, and how many are failing in this way? How many are working?

Thank you for making those measurments, Carl. There is another point on the board I would like you to measure, if you feel comfortable with it. It is pin 7 on the microcontroller, shown below. As you can see, it should be electrically connected to the resistor that Carl measured, so I would expect it to have the same voltage. However, if it has a different voltage then that would indicate a problem with that the trace and would explain the problems you are having. Please be careful when measuring this pin; if the multimeter slips you could cause a short circuit to an adjacent pin.

In total, I would like to know the voltage on VCC, VIN, the resistor, and pin 7.


hii David

I have checked the voltage on the terminals 11.1 volts and on the points marked i have 3.6V both on resistor and the chip. Using Atmel studio i tried program without the display fittet and the unit seem to respond did erace the program. I have tried with and without the display fittet , and with display fitted looking at the DEVICE PROGRAMMING , I get the target voltage ,but no device signature, without the display fittet , it works fine and i have now loaded the svp demo program and it works , is it normal it has to be programmed without the display ?
I bought 3 x orangatan 1284p

regards John

Hello, John.

That is very interesting that you can only program it when the display is off. How many of your three Orangutan SVPs behave like this?


Hi David.

We have 3 of them and are using 2, keeping 1 as a spare. Both the ones that we are using have the same issue and can both now read the signature with the LCD taken off. However, I am now receiving errors when trying to program it. Trying to program it with “Simple Test” from the examples in the bundle provided, I get this (pressing F5 to continue):

Failed to launch program.

Error: Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xc0, expected 0x00

And when trying to star without debugging I get this:

Failed to launch program.

Error: An error occured while executing command with ID 0x12. Timed out waiting for a response.

Turning to avrdude as another option and following the step for that I entered the command, changing for the SVP-1284P, COM port and file name, and for this:

C:\libpololu-avr\examples\atmega1284p\simple-test\Debug>avrdude -p m1284p -P COM
2 -c avrispv2 -U flash:w:simple-test.hex

avrdude: AVR device initialized and ready to accept instructions

Reading |                                                    | 0% 0.00savrdude:
stk500_2_ReceiveMessage(): timeout
avrdude: stk500v2_cmd(): short reply, len = 0
avrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500v2_cmd(): short reply, len = 0
Reading | #################                                  | 33% 30.06savrdude
: stk500_2_ReceiveMessage(): timeout
avrdude: stk500v2_cmd(): short reply, len = 0
Reading | ################################################## | 100% 45.11s

avrdude: Device signature = 0x020202
avrdude: Expected signature for ATMEGA1284P is 1E 97 05
         Double check chip, or use -F to override this check.

avrdude done.  Thank you.

Doing some troubleshooting lead me to the Pololu USB AVR Programming Utility but it cannot detect the device still even with all other programs closed and Device manager showing it is connected.

Have I missed a step somewhere?

Regards, Carl.

I have seen the “An error occured while executing command with ID 0x12” error happen a couple times, but I am not sure what causes it. Usually I can fix it by temporarily disconnecting the SVP from USB and powering it off. Does that work for you?

The Pololu USB AVR Programmer Configuration Utility is for a different product.


No it does not seem to work at all. I can tell however that the original program has change because the red LED is not flashing, buzzer not going off and nothing on the LCD. But the program I tried to put on there is not working (or no signs of doing anything).

I try to F5 many times and it will now sometimes Time out with error 0x14, 0x13 and 0x12. It either stops at erasing (%14) or writing (%32). Still not sure why it’s not working. Is there any way to reset everything and start again?

I’m sorry you are continuing to have trouble.

You can reset the state of the SVP’s auxiliary processor by just making sure it is powered off. The surest way to do that is to disconnect USB, disconnect the VIN power supply, and disconnect any other thing you have connected to it that has its own power source.

It is also a good idea to reboot your computer because sometimes the Microsoft USB drivers seem to get into a weird state. Rebooting also means you will be restarting Atmel Studio 6, which could help.

Doing the above steps will not reset the contents of the flash on the ATmega1284P. To erase or write to it, you would need to get some programming software working.


We have now got it loading programs on to it and running them. Thank you David for all your help.

Cheers, Carl.