Servos not working on Maestro 24

Ok, here are the steps I have taken so far:

Installed the software as instructed. Win 7 shows device is working properly. Device manager shows no errors on the ports.

Maestro Control Center shows no errors and is connected.

Leds on device: Green led rapidly blinking, yellow led off…then two quick blinks…off then two quick blinks.

USB connected for communication. 6v power supply (4 AA) batteries connected to the power input screws. Verified with multimeter. HD 1800A servo connected to channel 0 with signal wire toward the interior of the device (per pinout diagram)

When I drag the slider back and forth I get no response at all. I’ve tried all the different serial modes. I tried different servos, analog as well as digital in channel 12. I set VSRV=VIN as per the manual for a single power supply. I’ve run out of ideas. Anything obvious stick out in my description? Help!!


You mentioned Channel 0 and also Channel 12. Which one is the servo connected to?

You said you tried all the serial modes: just make sure you are not in auto baud rate detect mode (any other serial mode should work).

Everything else you described sounds correct.

Make sure you connected your batteries in the correct orientation.

Do the servos twitch a little bit when you connect them to the Maestro? Some servos I’ve used will twitch when you power them up.

If you have an oscilloscope, or just an LED, you could use it to see if the Maestro is actually generating a signal on the servo signal line.

If you posted a good photograph or two maybe we could spot something that looks wrong.


Uggg. Murphy’s law. I have no idea what I did different, maybe just letting it sit overnight. But it’s now working seemingly fine. I think maybe my power supply was not functioning perfect. All good now. Thanks