Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Servo not moving arm - will turn on light


Hello! Relatively new user to servo controller and I am using an inherited system for my research. Basically we are using the servo to move a food hopper up and down via an arm and turn on a light.

When using the maestro control center, I cannot get the arm to move, but I can get the light to turn on. I don’t think it’s a power supply issue since we are using an outlet and a USB


I am using a Windows 7 computer and I have attached pictures of the wiring and maestro control center window.



Hello, Mary.

Can you provide a link to your servo’s specifications and a picture of what it is trying to move? What are the voltage and current ratings of your power adapter? Can you verify that your servo is working without any load on it?

From the screenshot of your Maestro Control Center, it looks like channel 1 is set to servo mode and enabled, but there is no servo connected to that channel on your Maestro. Were you also trying to control another servo in your system?

- Amanda


Here is the link to the exact servo we have https://www.pololu.com/product/1047 and we also use this type of servo that is experiencing the same issues, https://www.pololu.com/product/2145.

This is the load we are trying to use, but I’ve been testing the servo without any load and it still won’t move. However, when I physically move the servo arm I can, so it isn’t stuck or anything.

This is the adapter we are using http://global-power-adapter.com/new-mlf-mlf005w0501000c-ac-adapter-5v-03a-mlf005w0501000c-p-1175.html?language=en but we didn’t get it from that vendor. I’m not sure what you mean by ratings.

I wasn’t trying to control another Servo, just experimenting :blush:



Judging from the specifications of your servos and power supply, it does look like a power issue. Both servos you linked have stall current ratings greater than what your power supply is able to source, which is up to 300mA (0.3A) as stated on its product page. (You can find the stall current ratings for both servos on their product pages either under the “Specs” tab or in their datasheet under the “Resources” tab.) You should make sure that your power supply can handle the maximum current draw of your servo as well as anything else in the system (like microcontrollers). A wall power adapter like this one would probably work. You can see all of our wall power adapters here.

By the way, since you are new to using servos, you might be interested in reading our series of blog posts about servos, starting with this one.

- Amanda


Sorry I should have mentioned this initially, but the servo was working a week ago, which was one of the reasons why I didn’t think it was a power supply issue. Since it was working previously with this power source do you still think it could be a power issue?

I’ll check out the blog posts, thank you!


What changed in your setup between when it was working and now? If your servo was working before, it is possible that your servo was damaged somehow. Can you try moving your other servo without any load on it to see if it is (still) working?

- Amanda


The other servo is not working either but was before. I really don’t know what happened, the unit is screwed in place (the metal part my hand is holding) so it’s not like it could have been dropped. The wiring is protected by a plastic cage so none of my research assistants would have even touched those. As far as I know nothing has changed.


At this point, it seems like both your servos might be damaged, which is unfortunate. However, to be sure your issue is not your power supply, can you measure the voltage of the Maestro’s servo power rails using a multimeter (if you have one) to see if it is still outputting 5V? Also, can you send a close-up picture showing the specifications (or ratings) on your power adapter? There should be a sticker on the device detailing its power ratings.

- Amanda


So I measured it with a multimeter and it is outputting 5V.



It is not clear from your post, but did you measure 5V from the Maestro’s power rails while the Maestro and adapter were both connected to your system? If not, can you measure the power rails and confirm there is servo power on the Maestro? Please make sure that your Maestro, the weaker servo, and power supply are disconnected from your food hopper system to keep the test setup simple.

Just to clarify, when you tried moving either of your servos, did it sound like they were trying to move but could not, or were they not responding at all? Can you describe the on-board LED behavior after you tried moving one of your servos?

Also, can you post your Maestro settings file to see if there is anything odd about your settings that could be causing the problem? You can save your settings file in the Maestro Control Center by selecting File->Save settings file.

- Amanda


Hi! Sorry for the delay in my response.

I’m not 100% sure where the power rails are, so I’ve attached a picture of where I measured it. When measuring from that point I was getting a pretty consistent reading of 4.5 I’m sorry if the picture isn’t very informative, it was a little tricky to take one handed.

When I tried moving the servos, they aren’t making any sound, so they don’t seem like they are responding at all. The LED behavior is a constantly flashing green light and and orange light that is off for approximately 1-2 seconds, then it flashes twice in quick succession. This does not change during or after attempting to move the servo.

Attached is the servo settings file
maestro_settings.txt (2.5 KB)

Thank you for your patience!


From your picture, it looks like you are measuring the voltage across the signal rail and servo voltage rail, which is wrong. The power rails are the VSRV and GND rails shown in the picture below:

Before you try measuring the voltage again, you should remove the connections to the PCB02A 8-pin PIC prototyping PCB board from channels 6 and 10 on the Maestro:

Please post another picture showing the test setup and let us know what you measured.

According to your settings file, channels 6 and 10 are set to output mode. What are those pins used for? Can you post close-up pictures showing both sides of the PCB02A 8-pin PIC prototyping PCB board so that I can see how everything is routed?

- Amanda


So this time I think I measured the correct rails, the ground and the servo voltage. I put a square around the two I measured since it was impossible to get an accurate picture. When I measured it was consistently giving an output of 5 volts.

Hopefully this picture also serves the function of providing an accurate look at how the front of that board is wired. Here is a picture of the back

I don’t believe the outputs that were assigned to 6 and 10 are in use. I just looked at an older setup and they used to power a different set of lights, but no longer.



It is hard to see the power connections on the prototyping board in that picture, and it looks like the solder joints on the back might not be making a great connection, but if you are measuring 5V across the VSRV and GND pins, that it is probably okay. At this point the most likely suspect is your servos. Can you try to get a different servo that you have not tested in your system before and know is working (if possible, you might borrow one; if not, you might get a replacement for your current servos in case they are damaged). Connect the new servo to channel 0 and try moving it with the slider in the Maestro Control Center. If that servo moves, your servos are probably damaged. If that servo does not, we will know to take a closer look at your Maestro.

By the way, your latest pictures show a heat sink on your Maestro, which was not there in the picture in your first post. Why did you add a heat sink? Are you using a different Maestro than before?

- Amanda


The set up does work with a different servo, so it does seem like that is where the problem is.

For the new pictures I was using the other set up that I mentioned that had the same problem. However, I will trouble shoot the original to ensure that the problem is with the servo and not the maestro. We added the heat sink because we noticed that the servo was getting quite hot during use and we thought that might be contributing to the damage.

Is there any particular model of servo you recommend using? We are currently using micro HD-1810mg, but it seems to break down frequently. The food hopper that it has to hold and move weighs 6.5 ounces or 186 grams. While it doesn’t have to move it a far distance or at a very fast speed, it does have to move back and forth on that small range very frequently. To make matters worse, we’re also on a budget. With our task demands, are servo damages of this nature just expected?

Thank you so much!


I am glad to hear one of your Maestro units is working, though it is too bad your servo is damaged. If the servos were getting hot in your application, most likely they are underpowered for the application. Do you have any particular size constraints? If not, this Power HD Standard Servo 6001HB might be a good choice for a replacement as it is much stronger than the HD1810MG. You might also consider the FEETECH High-Torque Servo FS5115M as it’s even stronger (so it should have no trouble with your load) and has all metal gears, but you might need a more powerful power supply for that one, such as this 5V 3A wall power adapter.

Also, if your servo does not need to move quickly, I recommend using the Maestro’s speed and acceleration limiting features to help reduce the average current draw and wear on your servos. You can find more information about the speed and acceleration settings and how to configure them in the Maestro User’s Guide.

As far as how often you should expect to need to replace a servo, that depends a lot on how active it is in your application. Can you estimate the total run time of your HD-1810MG before it failed? How many times do you activate your servo per day, and how long does it run per activation?

- Amanda


One of the servos was only 6 months old. They are active up to 400 times a day, but they only for a second or two. We really only use them to move the food hopper up and down and inch or so. Our set up is designed to house a micro servo, but it could be expanded to accommodate a standard sized servo.

Speed isn’t very crucial so I’ll definitely look into the speed and acceleration setting!