Servo Controller working weirdly


I implemented some time ago a software for controlling servos through Pololu Micro Serial Servo Controller, and it worked perfectly fine. Now I’m in need of using it again, and the servo controller is functioning in a strange manner. The software is exactly the same (I even used sample programs from Internet that I used in the past), but the hardware changed. However, I can’t see any problems with the hardware either. The servo controller goes nuts in the extreme values (for example, above 4800 and below 1250, for Pololu protocol) and enters error state (red light on, green light flashing quickly). I am using baud rate 19200, as I always used. For MiniSSC II protocol, I tried baud rates 9600 and 2400, but both generated errors (red light on, yellow light flashing slowly).

Another thing I noticed is that when I first implemented the software, after I plugged the power supply, the light was orange, and then as soon as I started to send commands to the controller, the yellow light went off and the green light flashed when the command was received. Now, sometimes it is putting the yellow light on again after the command is executed. Usually this happens in the extreme values, but sometimes it occurs in any random value too.

The point is: nothing like that happened in the past (not even extreme values problems), and now it is happening.

I am using a power supply of 5V for both servo controller board and servo. Just one servo is being used, in position 0. I already tried to change the position of servo in the board, I changed the servo, the servo controller, the usb-serial adapter… I think I already changed everything!

So, if anyone has any suggestion, it will be welcome. I’m out of ideas right now.

Thank you!


Did your power setup change? It sounds like your servo controller is resetting because of glitches in your power supply. Does the problem go away if you use a separate logic supply?

- Jan

Hello Jan!
Thanks for your reply!

In the past, I used a 6V power supply for powering the servo AND the servo controller. Now I’m using a 12V power supply regulated to work as 5V (and it was checked, it is indeed 5V), so the only change was that: 6V to 5V, which should work according to the manual.

And what do you mean by “separate logic supply”? Forgive the ignorance, but I’m a complete noob in electronics :smiley:


There are pins for the servo supply and pins for the logic supply. You can connect separate power supplies to each of them. How are the two supply inputs connected to your 5V supply right now?

- Jan

Oh, got it! I was using the same power supply, I hadn’t tried separate ones.

Anyway, I figured it out what was the problem. I thought the power supply I was using was a bivolt one, and it was not. It had an input voltage selector switch, which was at 220V, and I was using it in 110V. I just didn’t see the switch.