Servo Controller Connection Problem

I have purchased 3xMini maestro servo controller card for three different projects.

One of our project is to move a scale model between 70, -10 degrees. Our model must be fully working 8 hours per day. We setup our configuration and everything works fine. However, after some working time card gives an error to the application that I wrote (something like cannot connect to servo controller). At first I thought that there is a bug in my application. After investigating further, same error arise when I try to control our model using mini maestro control centre. After observing this I thought the problem is related to this specific servo controller. The error fixed when we reconnect controller (by switching off its usb cable and reswitch it to our computer).

In another project I have used another mini maestro servo controller. In some random time (I was unable to identify when error comes. Sometimes it arise after working 4 hours, sometimes it comes after 20 minutes) I received same error.

I am curious if you have received this type of problem before. Is there any update for your card?

here is our setup,
2xstandart servo (both of them connected to same port)
1xmini maestro servo controller
1x6V 2.5A power adapter (for 2nd project we used 1x5v 2A adapter)

Hello, yaskil.

I’m sorry you are having trouble with the Maestros. I think one of our customers might be having a similar problem.

What operating system are you using? If it’s Windows, then I know a few things you could try.

When your application encounters an error, what error message/code are you getting and what API/library is it coming from? Could you tell me the exact error message that happens when you try to use the Maestro Control Center?


Hi David,

Thank you very much for your response. Operating system I am using is Windows XP.

The time I lost connection depends. It happens in different times and different circumstances, nothing special. I receive exception from .Net API (no error message specified) and also I receive connection to controller lost error from maestro control centre. When I try to reconnect something like unable to connect card message comes.

Also when I embed a script to the controller it works very well.


Could you please try disabling the Selective Suspend feature of Windows? You can do that either by editing the registry or by running a Microsoft Fix It program that will disable it for you. Microsoft provides instructions on how to do that in the section entitled “Method 3: Edit the registry to disable selective suspend mode for all USB host controller drivers in the system” on this page:

If the error happens again, could you please close your application and any Maestro Control Centers that are open, open up a new copy of the Maestro control center, and try to connect to the Maestro? If it fails, please let me know the entire error message. Also, if the error happens, please look in your Device Manager and describe the entries you see for the Maestro and tell me how the red, green, and yellow LEDs on the Maestro are behaving. All of this will help me figure out what is happening.


Hello yaskil. Did you disable selective suspend? Has the connection problem occurred again? --David