Serial Transmitter v1.3 problems

Hi I’m using a Pololu USB 16-Servo Controller, and am trying to send single bites to the controller to test it and to starting point for understanding how to program it. However I can get it to connect using the Serial Transmitter but when I send a byte in Mini SSC II Mode it has;

sent: FF (the synchronization value)
revived: FO ’ ã '
on the controller the top green light is on, the yellow light starts flashing and the red-light comes on signaling a fatal error.

I have used other programs to try to send data through but each time it appears to try and send or be access it a similar thing happens with the red light coming on and nothing else happening. I have try uninstalling the drivers and then reinstalling them but no luck, it is probably something obvious that I have missed or can’t think of can you please give me some pointers in the right direction?



What baud rate are you transmitting at?

- Ben

SSC II Mode i’ve tried at both 2400 and 9600 baud.


I don’t see anything obvious you’ve missed from what you’ve posted. After you connect the servo controller to USB, do the LEDs briefly turn on in sequence before leaving just the yellow LED on? Do you have the jumper on for Mini SSC II mode? Do you have another computer around on which you could try it?

- Jan

Thank you both for the quick help, I tried the controller on a different computer and it worked. The problem is probably with the drivers or other software on the computer interfering.
The yellow and green lights are both on before data is sent but once data is sent then the two green lights come on and the servo moves into position.

Thank you both again for the quick relevant help.