S7V8F3 powering RFDuino


I recently bought 2 of those 3.3V regulators from one of your suppliers. One of the came damaged but works to some extent. The second one works fine but I am experiencing something I did not expect. I am planning to use this regulator with a 3.7 V LiPo battery to power up the RFDuino. It draws maximally around 20 mA when transmitting and otherwise around 12-13 mA. The problem here is that I thought that the regulator will be able to power it up through the whole capacity of the LiPo but that seems untrue. I tested it first with a table DC source (function generator) and tried to supply voltage in range from 3.1 to 4.2 V to simulate the whole cicle of the useful LiPo charge. The regulator is unable to supply the desired 3.3 V output unless the input voltage is higher than 3.5 V initially. When I cross this threshold it operates normally until the specified 2.7 V but sadly that is not that useful to me because the battery will get flatter and when it goes under 3.5 V (which is cca less that half/half? of the LiPo cicle) then it will not be able to power up the regulator to supply desired voltage to the RFDuino. So my question is simple :slight_smile: Is this the usual behavior? If so why is it not clearly stated on the product page? I have not been able to find this information there… If it is so these regulators are simply useless for me now. Thanks for your answer.


I am sorry you are having problems with your regulators. How did you determine that one of your boards is damaged? Could you explain what you mean when you say that it “works to some extent”?

The S7V8F3 should be able to turn on when supplied with voltages as low as 2.7V. You mentioned that you are using a function generator as the input to the regulator. Do you know how much current it can supply? Do you have another source you can try, like the LiPo battery you plan to use later?


The IC has one of its corners chipped of. It works as the first one but the output voltage is little higher. First I thought that this is a problem and because of that it does not start to work at 2.7 V but I experienced the same issue with the second one so even though it has a chipped corner it looks ok so far. I measured the current yesterday and at 2.7 V it was around 17 mA and got progressively higher until the regulator switched on. Then it went to cca 40 uA with no load attached. At around 3.5 V drawn around 30-35 mA not sure exactly. I will try another source hopefully they will work ok :slight_smile: Thx for a quick answer.

Ok I tested it with proper voltage source. Works like a charm even the one with chipped corner. Sorry for false alarms and thanks for suggestions :wink:

I am glad that using another source solved your issue. Thanks for letting us know.