Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Romi boot failure

I’m running the FRC version of Romi. I updated the firmware, web services, and calibrated the gyro. Everything worked fine for the first two days. 10 minutes after booting on the third day the robot started playing a high pitched 5-note tune over and over, while failing to activate its wifi. It continues to do so, though the tune has changed a few times. With no wifi access I’m unable to refresh the firmware. Is there some way to recover from this?

I’m having a very similar issue with the FRC version. Things worked okay the first day and everything was updated, but now when I power the device up, I am experiencing the exact behavior you are. Nothing I can do seems to fix it.

I did power up the Raspberry Pi and Romi separately with the RPi not physically mounted to the Romi in an attempt to troubleshoot. Connecting the provided USB cable to the Romi micro-SUB port and a USB port on the Pi did allow me to update the firmware. But the beeping/no-wireless behavior still exists after mounting the Pi on the Romi and powering it all up again…

Hello.

From your description of the problem, it sounds like your robot might be resetting. Have you verified that the batteries are freshly charged? If so, could you measure the voltage on the VBAT pin of the Romi 32U4 Control Board to see if it is dipping when the robot is powered on?

If that is not causing the issue, then it is likely a software problem, so I recommend reaching out to the WPILib team for troubleshooting assistance.

Brandon

I replaced the batteries with brand new ones and the problem’s gone. Thanks!

Niall

2 Likes