Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Romi 32U4 no power from batteries

Hello all! I’m a mentor for an FRC team. We’ve been experimenting with these great little Romi robots for a few months now and our coding team has learned more in this short time than in the last four years. What a great little platform.

We bought a Pololu arm kit for our Romi and have been figuring out how to put it together, again, learning so much. We got all the servos working and the arm together and working before mounting it on the Romi. The problem came when we mounted the arm on the Romi. We put in the four screws to hold the arm in place, put in the batteries (all six) and nothing. No cheerful little beep telling us the board was powered, no lights, nothing.

It seemed odd. I thought maybe the standoffs had touched something on 32U4 but it didn’t look like it. I took the four screws out and disconnected the servos. Reinstalled the batteries and still nothing. Now I’m starting to get a little concerned.

I connected a 5V battery to the micro-USB port and it powered up but the buzzer seemed to be signaling an error code every 3 seconds or so. I re-connected the Pi and powered up the board with the 5V battery again. The Pi booted and I connected to the WiFi. Everything looked normal on the Romi web page. I re-flashed the 32U4 from the Pi and that was successful but still no change. The buzzer still gives, what I assume is, an error code and the board won’t power from the batteries.

I read through several posts and someone with a similar problem was recommended to re-solder their battery connections. I did this but it didn’t change anything.

So, I’m a little stuck and really hoping that someone out there might have some suggestions.

Thanks for reading.

Hello.

Just to clarify, did your Romi 32U4 Robot work fine until you connected the servos to it? How were you powering the servos and how did you connect them to your Romi Robot?

Could you measure the voltage at the VBAT pin on the Romi 32U4 Control Board? Also, could you measure the voltage at VREG when the robot is powered from the batteries? I have indicated where VBAT and VREG are in the picture below with a blue and yellow circle respectively:

Brandon

Hi Brandon,

Thanks for your response.

Our robot worked fine before and after connecting the servos. I soldered header pins on the front like in the photo and then just connected the servos to the pins. The servos worked great and we were able to program the arm to function with a joystick.

0J7509.1200.jpg

We didn’t have problems until we physically mounted the arm onto the robot. We lined up the standoffs, installed the four screws and then when we put the batteries in the robot seemed dead.

I have been able to power the board by connecting a battery pack to the micro-USB.

I get 8.17 volts on Vbat but nothing on Vreg. I assume that means there is something wrong with the voltage regulator circuit. Any suggestions on that?

It seems unlikely that just mounting the arm on the Romi would damage something, so I think we should look for other problems first. The main thing that jumps out at me is your 8.17V battery voltage, which makes it seem like you might be using mostly depleted alkaline batteries. If that is the case, can you try replacing them with freshly charged NiMH batteries or brand new alkalines (we generally recommend NiMH batteries for robots because they can deliver higher currents with less of a voltage drop than alkalines)? Also, can you try disconnecting the arm servos for now while we try to get your board working again?

By the way, please note that the 5V regulator on the Romi 32U4 Control Board cannot supply enough current to power all of the servos in that arm. Usually drawing too much current would just result in the voltage dropping and the board browning-out and resetting; however, it’s also possible that this could damage the regulator. We recommend using a higher-power external regulator to power the arm servos. You can find more information about this under the “Powering the servos” section of the Robot Arm Kit user’s guide.

Brandon

I agree that mounting the arm didn’t likely cause any damage. The batteries I had in the Romi were NiMH batteries fresh from the charger which is why the voltage was high. I just measured them again and they are 7.8V.

Disconnecting the servos and the Raspberry Pi were the first things I did when I started having the problem so there is nothing connected to the board. At this point, the board is mounted to the chassis. The drive motors are still in place but other than that, nothing is connected to the board.

Thanks for the tip about 5V regulator and the servos. I had read about the possibility of a brownout situation. I also read that it was pretty easy to over volt the servos if they were powered directly from the batteries. Just got too excited to play around with the arm to build a separate circuit. I’ll check out the documentation you referenced.

Thanks