Revive A-Star, Arduino IDE,

Hello, I’ve got a A-Star 32U4 Micro and it’s stopped accepting uploads from Arduino IDE 1.6.5. It was originally working, i loaded some sketches after it first arrived. The error I get is: “can’t open device “/dev/cu.Bluetooth-Modem”: Resource busy” … I’m on OS X.

So I tried following along with this, under section 10.1:

I’ve successfully attached the reset button, and I see the orange light flashing after I push button twice. However I never get the new serial port that’s referred to multiple times in each of the paths for fixing it. I look either in the arduino IDE or on the terminal under /dev/ and I never see a new device pop up, nor can I get the Arduino IDE into a state where no port is selected, or the menu is greyed out as the directions say.

Any ideas?


I am sorry you are having problems programming your A-Star. Could you tell me more about your setup? Do you have anything else connected to the A-Star 32U4 Micro other than the reset button? What was the last program you uploaded on to the A-Star? Could you try programming the device using a different USB cable and computer?

- Jeremy

Jeremy - thank you for the suggestion; a new USB cable fixed it right up. It’s working now. Bravo to you, thanks again.