Random behavior of h-bridges

problem in speed/direction conrol of dc motors:
I’m using two H-bridges with 2 (12V) motors(details below), they were working just fine(although i had noticed the problem once but it never happened again)(used them previously on a balancing robot project)

the problem started when i changed the circuit ,motor control never worked again as before(i.e sometimes it works and most of the time it doesn’t)
weird things happened in some tests: backward motion is ok
forward is not(the motors were like vibrating and rotating in small steps)
mistakes i did: i accidentally connected 12v to the enable pin (i fried my ex-arduino )
but as mentioned below i tested (the h-bridge) and it was working (alone).

components:

L298n h-bridg (multiwatt 15) // for the first motor
L293D h-bridge //for the second one ,i used 2 of them to avoid over heating

(29:1) Pololu Metal Gearmotor 37Dx54L mm

Arduino uno R3 (ATmega 328p-pu uc)

tests I did:
-i separately tested the outputs from each channel of both H bridges,by directly applying 5v to inputs and measured the outputs ,they all worked as expected. (i noticed that when applying logic 0 to one of the inputs the corresponding output pin does not give exactly 0 volt!)

-i put a led on one of the inputs to check weather the arduino is giving out the right signal… the led becomes ON whenever the motor shall rotate (so i guess no problem with arduino output).

-i used PWM signal and i also tried giving only high/ low (no speed control) and the problem remained.

-i also checked the motors, using an external dc power supply,they worked very well in both directions,although it seemed to me the motors are faster in one direction than the opposite one (motors noise sound different in each direction)
-also tried using only 1 h-bridge.
-i also enhanced the ground bath by adding extra connections (i saw that on one of the forums)

that’s it>> hope i gave you all needed info.

Hello.

Since this is not an issue with a Pololu motor controller or driver, I have moved this thread to the general robotics forum. If your setup was working and is not now, something might have gotten damaged or connected incorrectly. You might carefully double check your connections and make sure there isn’t an obvious problem. I also suggest trying again with new motor drivers like our dual MC33926 motor driver shield.

- Jeremy

i reconnected everything and it worked!! the forward intermittent motion was because a delay in the code!!

I’m glad you figured it out and got it working.

- Jeremy