Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Question about possibly under powered servos

So I think it’s a power issue but I can’t seem to narrow it down. In part that I am completely new to this.

I have the Maestro Micro and I’m trying to use two MG90S’s. I’m powering the Maestro by USB and the servos with a 6V 2000mAh battery. When I try to move the servos using the Maestro controller they BARELY move. I’d describe it as like the ticking of a second hand, only slower.

The battery is fully charged and brand new. I also tried to use a 9V battery and I saw the exact same result. It’s also the same for one servo or two. I don’t have another source of power to test with but something doesn’t seem right.

I’ll mention (because I don’t know if it matters) I’m running the controller program from Bootcamp on a mac.

Hello.

Could you post a copy of your settings file? You can save your settings file from the “File” drop-down menu of the Maestro Control Center. Additionally, can you post some pictures of your setup showing all of your connections?

Also, do you have anything else you can use to test your servos separately to make sure they are not damaged (e.g. an RC receiver/transmitter or separate microcontroller like an Arduino)?

Brandon

Thank you for your reply. Here are the setting file and setup. It’s very basic since I’m just trying to get the servo powered.

maestro_settings.txt (1.5 KB)

Here is a gif of the servo.

I don’t have another means to test the servo. If you think they are damaged I can buy another one.

Thank you for the additional information. Your connections look okay. I noticed from your settings file that you are using a period of 10ms. Could you try changing the period to 20ms at the bottom of the “Channel Settings” tab to see if that makes any difference with your servos?

Brandon

Hi Brandon.
I tried to update it to 20 ms and applied the setting but it had no effect. Not only that but whenever I went back to that tab it reset to 10 ms again.

In order to set the period to 20ms, you will need to first set the “Servos available” to at least 4. Note that it is okay if this number is higher than the number of servos you are actually using. Could you try making sure the number of servos available is set to at least 4, then setting the period to 20ms and trying again?

Brandon

Hi Brandon,
I was able to set it to 20 ms after that but the result is the same.

What voltage is your battery pack measuring? Can you try measuring the voltage while the servos are moving to see if it is dropping and if so, by how much?

Brandon

Hi Brandon,
The pack was showing ~6.5 V it dipped a little when the servo moved but not below 6V

That battery voltage sounds normal. When you move the slider in the “Status” tab of the Maestro Control Center, does the green dot stay on the handle or does it lag behind and follow the movement you are seeing from your servo?

If you haven’t done so already, you might also try moving the servos to different channels on the Maestro.

If the green dot stays with the handle on the slider and changing to different channels does not help, I suspect your servos might be the problem. In particular, it might be possible that they were damaged when you powered them from 9V (which is higher than most servos are rated for).

Brandon

Sure enough, it was the servos. I replaced both of them and the new ones work like a charm. I only tested the 9V on one of them so I think maybe I just got some knock-off amazon crap. Regardless, thank you for your help. I’m bought my Maestro on Amazon and I’ll be sure to leave a review mentioning how helpful you have been.