Question about I/O Extender App

I purchased two Wixels and finally got around to connecting them and going through the User’s Guide. I installed the I/O Extender App and it runs as advertised when the USB cable is powering the circuit but when I disconnect the USB cable and apply 5 VDC directly to the “VIN” pins, they no longer function and the yellow LED stays lit. I connected the USB cable to an iPod charger (5VDC USB Connector) and the app worked fine then as well.

My question is: “Will this app only work when power is applied through the USB cable or is it possible to just apply power to the VIN pin and function correctly?”



The I/O Repeater app should work fine with no USB connection and power supplied through VIN. What connections have you made to your Wixels? How are they configured? (What parameter values did you change in the Wixel Configuration Utility?)

The app uses the yellow LED to indicate that there is power present on VIN, so you should expect to see it on if the app and Wixel are working correctly.

- Kevin

The App is just using the default parameters:

P0_0 link: -1
P2_1 link: 1
radio channel: 128
(all other I/O pins are set to 0)

This was used to program both Wixels I am using for evaluation. I then placed the Wixels in a breadboard and applied power to the VIN pin on both Wixels and GND from the supply to both Wixels. I am measuring approx. 48mA total while both are operating (I/O extender app is not working though). The supply I am using is an Agilent bench top supply and the supply voltage was measured at the VIN pin to be 5.0 VDC.

I have a wire connected to P0_0 and when I ground it, the red LED on the other Wixel should turn off. When they are running from the VIN pin, the red LED is not lighting at all. As soon as I power the board from the USB connector, it works fine though.

I got it to work. Originally I had the supply turned on to output 5VDC (left ground disconnected from the circuit) and then I just made the connection to the circuit because there is a small rise time on my supply. Apparently the Wixel did not like this and would get into some state where it was apparently not reading the app?

I then left everything connected and just cycled power on the supply and it worked fine. I am going to repeat this test with a battery to see if I am going to have the same issues.

I am curious to see if anyone is using this app (I/O Extender) with a battery. The only way I was able to get it to function was to put a RC circuit in front of the circuit power in order to delay the rise time. Once the rise time got above 100ms, everything worked fine.

Has anyone else experienced this issue?

I have the same problem with the same app. I’m trying to power it using a 5V 2A wall adapter. It only works if I power up using USB first. But if I power directly from the adapter, the apps don’t start.
Any suggestions??

What is even stranger!! If I start by connecting only one through USB, then using DC supply for the other it works, but it never works if I start both with DC supply, even if I later connected to USB!!


I looked into it a little bit and was able to reproduce the problem here. Whenever two transmitting Wixels running I/O repeater app powered up at the same time, the timing of the packets they sent were synchronized so neither Wixel ever succeeded in receiving a packet from the other Wixel. The apps do start, but they never succeeded in communicating with eachother. There were several workarounds (e.g. powering the Wixels at different times or resetting one of them).

I have made a new version of the I/O repeater app (v1.3) that fixes this problem by adding some ADC-generated randomness to the timing of the packets. You can get the new version from the Pololu Wixel User’s Guide and it should solve your problems.


Thanks a lot, will give the new app a try