Quad Encoder not reading on SVP1284

I testes it in analogy of demo program and the encoder signals on A and B is OK on peak and sequence, but it could not read when I ran a Pololu listed or encoder programs. It shows read=0; error=1 whatever motor driven or turn by hand . I swapped A to B, but the result was the same. I could not find what was wrong. Do you have a Pololu encoder demo program to test it?

My motor is Faulhaber 1516SR012 with CR16 encoder.


You can find an example program for quadrature encoders in the “Pololu Wheel Encoder Functions” section of the AVR C/C++ Library User’s Guide.

If you continue to have problems, could you tell me more about your setup? How do you have the encoders connected to the Orangutan SVP? Could you post pictures of your setup?

- Jeremy

I used SVP function (SVP_MODE_ENCODERS mode) and A B port for quad encoder, Not wheel encoder function. Could you add a sample program for it?

We do not have an example program for using the Orangutan SVP in the SVP_MODE_ENCODERS mode. However, the commands for using the auxiliary processor with quadrature encoders can be found in the “Orangutan SVP Functions” section of the AVR Library Command Reference.

- Jeremy

Get another and return the old. It works now. I believed the auxiliary processor did not communicated with AVR on both of USB communication and quad encoder function, but it works on USB programming and analog function fine so I did not know what the root problem was. I just happened to find it read sometimes when I removed mini USB from the controller so I decided to change one and the case is over.

I’m glad you figured it out and got it working.

- Jeremy