Qtr 8a reflectance sensors are not working properly

we are trying to use the pololu qtr 8a reflectance sensor array for our line follower. However, when we are running the example programs we are getting erroneous results. When we ran qtra example program we got random results. Even when we just directly used analogread() we got random values in the result which didn’t change on the basis of the surface under the sensor. We tried calibrating multiple times but the result remained the same. When we tried to check the voltage read at pins when placed above different surfaces, we just got 0 volts on the multimeter, irrespective of the surface. Could you please help us with this at your earliest convenience.


I am sorry you are not getting the behavior you expect from your QTR-8A array. Can you tell me more about your system? Has the array ever worked for you? What controller are you using to run the example program? How are you supplying power to the array? Can you post pictures that clearly show your connections?