Programming my Orangutan SVP-1284 with AtmelStudio 6.2


Today is my first time that I try to program the board and I have “Little” problems.
My computer hav Windows 7 and Atmel Studio 6.2 and the sistema detect perfectly the board:

Some questions:

  • Can I programm the board directly using a USB cable, right?
  • I need to cut any track or put any jumper?
  • In the Atmel Studio 6.2 what COM I need to choose? COM7 Right?

When I choose the COM7 in the Tools → Add Target nothing occurs and nothing is saved.

After compile the program and press F5 to program, this is the error that appears in my screen.

What is wrong?

Thanks a lot!


Yes, you can program the Orangutan board via USB.

You do not need to cut any traces or apply any jumpers to program the Orangutan. If you want to know more about the board’s jumper options and labeled traces, I recommend reading the Pololu Orangutan SVP User’s Guide.

You are correct. The Programming Port (COM7 according to your Device Manager) is the correct port to use.

From your error message, it looks like there is no tool or interface selected in the “Tool” menu. Can you click on the drop-down menus and post screen shots of them here? Is the blue power LED on? You need to supply external power to the Orangutan SVP before it can be programmed. (If the blue power LED is not on and you have an appropriate external power supply connected to your board, you will need to push the power button to supply external power to the board. You can look at the pictures on the Orangutan SVP-1284 Robot Controller’s product page to locate the power button as well as the blue LED, VIN, and GND.)

- Amanda

Hello Amanda,

of course the blue led is ON and the board is working with the “DEMO PROGRAM” because the board is new. At 12Vdc in the Vin connector the board consumes about 35mA (without LCD Screen).

This is the screenshot of the window “DEVICE PROGRAMMING”: I cannot choose any tool and I don’t know why.

Any Idea?


I noticed, from you screenshot, that the “Simulator” is not present in the “Tool” list of the “Device Programming” window. It looks like you might have a bad install of Atmel Studio 6.2. Can you try re-installing Atmel Studio and see if the “Simulator” is listed as an option under your “Tool” list?

- Amanda

Hello Amanda,

after reinstall the program, the problem remains…
In this video in youtube you can see more details about the setup:

Thanks for your help!

From your video, the “Simulator” option is still not listed under the “Tool” list of the “Device Programming” window. I tried installing Atmel Studio 6.2 onto my computer with an Orangutan SVP-1284 connected (and powered) to it, but I could not reproduce the problem. It seems like there might be a bug with your version of Atmel Studio 6.2. If you can make another video showing the following steps, it could be the basis of a good bug report to Atmel:

  1. Add an STK500 on the Orangutan’s Programmer port (COM7).
  2. Open the “Available Tools” window under the “View” menu.
  3. Open the “Device Programming” window and look at the list of available tools from the “Tool” drop-down menu.

In the meantime, you could try using AVRDUDE to program your Orangutan SVP-1284. For information about how to use AVRDUDE, see the “Programming with AVRDUDE” section of the Pololu AVR Programming Quick Start Guide. If you have trouble downloading WinAVR, you can alternatively use the version of the AVRDUDE that comes with the Arduino IDE.

- Amanda

Hello Amanda!!

Sorry for my delay answering the post, but I went out of my house for vacations :slight_smile:

I solved the problem updating the USB drivers from Atmel: “Atmel USB Driver Installer 7.0.888”. Latest versión is from this July.

But now, the problem is that I cannot program the board using your external “Pololu USB AVR Programmer”. The error message that show the system is:

Any suggestion? Any setup in the hardware?

Thanks a lot for your help!!

It looks like your are not supplying your Orangutan SVP-1284 with enough power. According to your screenshot, your Orangutan is receiving 4.4V, but the operating voltage range is between 6V to 13.5V.

By the way, the Orangutan SVP-1284 does not require an external programmer, since its auxiliary processor serves as a programmer. Please read the Pololu AVR Programming Quick Start Guide for more information about programming your Orangutan SVP-1284.

  • Amanda

Hello Amanda,

No, I’m powering the board with the correct voltage (9V). Also in the demo program installed in the board I can check that the uC are showing the correct Voltage in the LCD screen (9003mV). I checked the VCC signal and is OK (5V). Please tell me where I can check the voltage level of the Target Voltage: … iagram.pdf

The board is completely new and NEVER I connected external hardware.

Also, If I plug directly the USB cable without the “Pololu USB AVR Programmer”, my windows 7 don’t show or don’t know the board. Why?


I looked again at your screenshot and saw that the tool drop-down menu is grayed out, indicating that your AVR programmer was not connected in Atmel Studio. However, since the Orangutan SVP-1284 has a built-in programmer, I think it would be best to focus on getting the Orangutan SVP-1284 working with Atmel Studio instead of trying to troubleshoot both methods of programming the board at the same time. (If you want to use the AVR programmer too, we can continue troubleshooting that after getting Atmel Studio to program your Orangutan successfully through its own programmer.)

In one of your earlier posts, you posted a video link showing your Orangutan connected to your PC via USB and the Orangutan SVP-1284 drivers listed in your Device Manager. Did anything change in your setup since then?

- Amanda

Hello again,

To be clear… this is the difference of my Device Manager in Windows7:
When I connect the “Pololu USB AVR Programmer”:

This is the Device Manager when I plug the USB cable directly from the computer to the Orangutan Board (Without “Pololu USB AVR Programmer”:):

Screenshot of Available tools (Without “Pololu USB AVR Programmer”):

Screenshot error when I press the button “APPLY” (Without “Pololu USB AVR Programmer”):

I hope this info helps me to solve the problem.


It is possible that your COM ports might have gotten messed up in some way. Can you try unplugging and replugging the USB cable from your PC before trying to connect to your Orangutan to Atmel Studio? Another thing to try is restarting the computer. If you still receive an error message, can you click on the “Details” arrow in the error message window and post a screenshot of it here? Also, can you take a screenshot of the output pane at the bottom of the main window and post that as well? The output pane should contain a brief description of the errors that occur along with the error codes.

- Amanda


this is the requested info:

Timestamp: 2015-07-31 06:22:55.632
Severity: ERROR
ComponentId: 20100
StatusCode: 1
ModuleName: TCF (TCF command: Tool:connect failed.)

The signature of the attached tool is AVRISP_2, which is unexpected.


The error message indicates that you have an old version of the firmware. You should update to the latest firmware following the instructions under the “Upgrading Firmware” section of the Orangutan SVP User’s Guide.

- Amanda

Hi Amandaaaaaaaaaaaa!

Now it Works!! I’m happy !!
Thanks alot for your help and your patience!!
See you again in new questions in some days :laughing: :laughing: