Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Programming atmega328 through Pololu Programmer item 1300


Hi, I’ve been trying to use the pololu’s programmer pgm03A item 1300 using the arduino’s IDE and I’m getting an error saying “Error while uploading: missing ‘program.params.quiet’ configuration parameter”. I followed the steps mentioned here and here. The drivers are correctly installed I’m able to see signals with the program “sloscope” (I don’t know what the signals mean, I think it’s something to do with spi com) I can alter the configuration with “pgm03a_config” program as well and I’m able to set the pololu as the Programmer but when I try to burn it using him “Ctrl+Shift+U” I got the error mentioned. If I try to turn on the verbose I get the error: “Error while uploading: missing ‘program.params.verbose’ configuration parameter” I guess the programmer doesn’t support verbose.

PS: I’ve choose a board that has an atmega328 in my case the arduino duemilanove with atmega328 (the microcontroller that I want to burn). It also appears two COMs and I`ve tried them both.



Can you post screenshots showing the Tools menu of your Arduino IDE and your Device Manager with the “Ports (COM & LPT)” entry expanded? Can you run the Pololu USB AVR Programmer Configuration Utility (pgm03a_config.exe) after attempting to program your Arduino Duemilanove and post a screenshot of the utility window? How are you powering your Duemilanove? Please note that the AVR programmer does not power the target device, so you will need to supply power directly to it when programming it through the ISP headers.

By the way, the SLO-scope application just measures TTL-level voltages (between ground and 5V) using pins A and B on the programmer. You can find more details about that feature under the “Measuring Voltages Using the SLO-scope” section of the AVR programmer’s user’s guide.

- Amanda


Thank you for your quick reply Amanda. I’m posting the images below but first I’m pretty sure that the problem lies on the Pololu’s programmer configuration file that I’ve got from the git. When I turn the verbose on in the compilation and upload it says that the configuration parameter ‘program.params.verbose’ is missing and when I turn it off it says that ‘program.params.quiet’ configuration is missing. I’ve my device externally powered and I can see the yellow light blinking.


Hi, rsegecin.

Could you try selecting “Atmel STK500 development board” in the Programmer menu instead and see if that works for you?



It fails as well when it appears to start to program the red light comes up still and the yellow keeps blinking, here’s the output selecting the Atmel STK500 as the programmer:

PS: I’ve tried to use an arduino as the ISP and it worked I guess for while I’ll stick with this manner.

avrdude: Version 6.3, compiled on Sep 12 2016 at 17:24:16
		 Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
		 Copyright (c) 2007-2014 Joerg Wunsch

		 System wide configuration file is "C:\Users\RinaldiSegecin\AppData\Local\Arduino15\packages\arduino\tools\avrdude\6.3.0-arduino6/etc/avrdude.conf"

		 Using Port                    : COM6
		 Using Programmer              : stk500
		 AVR Part                      : ATmega328P
		 Chip Erase delay              : 9000 us
		 PAGEL                         : PD7
		 BS2                           : PC2
		 RESET disposition             : dedicated
		 RETRY pulse                   : SCK
		 serial program mode           : yes
		 parallel program mode         : yes
		 Timeout                       : 200
		 StabDelay                     : 100
		 CmdexeDelay                   : 25
		 SyncLoops                     : 32
		 ByteDelay                     : 0
		 PollIndex                     : 3
		 PollValue                     : 0x53
		 Memory Detail                 :

								  Block Poll               Page                       Polled
		   Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW    ReadBack
		   ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
		   eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
		   flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
		   lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
		   hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
		   efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
		   lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
		   calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
		   signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

		 Programmer Type : STK500V2
		 Description     : Atmel STK500
		 Programmer Model: STK500
		 Hardware Version: 15
		 Firmware Version Master : 2.10
		 Topcard         : Unknown
		 Vtarget         : 4.6 V
		 SCK period      : 8.7 us
		 Varef           : 0.0 V
		 Oscillator      : 3.686 MHz

avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
		 Double check connections and try again, or use -F to override
		 this check.

avrdude done.  Thank you.


The red LED indicates an error, so if you are interested in continuing to troubleshoot with the programmer, could you check the Pololu USB AVR Programmer Configuration Utility again (after the red LED comes on) to see what error is being reported?