Problems With I/O Repeater App

Hello. I have recently began using the wixel for a project needing simple wireless communication. When I purchased the wixels, they worked great. I had my entire project prototyped out on a breadboard for months. During this time, Everything worked. When I built a final circuit on some protoboard, things went down hill. After the wixel wasn’t working properly, I found a tiny piece of stray solder that shorted the 3.3v line to gnd. I quickly removed the power source and removed the solder. After that, the wixel seemed to be working like normal again. Later, I found out that the other wixel wasn’t receiving the input change. I believe I have damaged the wixel when I shorted it out, but it still receives the working wixel’s signal. Is it possible for the wixel to still be able to receive, but not transmit? I have reloaded the app countless times and have even tired changing the linked pins with no luck. I know for sure that the one wixel works because nothing has changed with it’s hardware.

I am going to go ahead and order another one to replace the “damaged one” just in case.

Thanks for your time,
Vinnie Marco

Hello, Vinnie.

I am sorry your Wixel was damaged, but I am glad you figured out what happened. In general, when a short from power to ground like that damages electronics, it can be difficult to determine in what way the electronics were damaged. So, the half-working behavior you described does not sound entirely unreasonable.