Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Problem with reviveng A-Star micro 32U4

I’m a noob and i bricked my controller by uploading sketch with wrong board stings.
No virtual serial port, no led on the board
Now I’m trying to compile avrdude on debian buster

$ make 
/bin/bash ./ylwrap config_gram.y y.tab.c config_gram.c y.tab.h `echo config_gram.c | sed -e s/cc$/hh/ -e s/cpp$/hpp/ -e s/cxx$/hxx/ -e s/c++$/h++/ -e s/c$/h/` y.output config_gram.output -- yacc -d 
updating config_gram.h
/bin/bash ./ylwrap lexer.l .c lexer.c -- :  
make: *** [Makefile:1924: lexer.c] Error 1

Any help on that error or where can I download binary of avrdude?

Nevermind. I was mising bison and flex packages.

Now I have problem with resetng the controler.

$ sudo avrdude -c avr109 -p atmega32U4 -P /dev/ttyACM0 -e

Connecting to programmer: .
Found programmer: Id = "CATERIN"; type = S
    Software Version = 1.0; No Hardware Version given.
Programmer supports auto addr increment.
Programmer supports buffered memory access with buffersize=128 bytes.

Programmer supports the following devices:
    Device code: 0x44

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.23s

avrdude: Device signature = 0x3f0d0d
avrdude: Expected signature for ATmega32U4 is 1E 95 87
         Double check chip, or use -F to override this check.

avrdude done.  Thank you.

Do I have to reflash the bootloader?

Hello. I am sorry you are having trouble with the A-Star 32U4 Micro.

I suspect your system has a program named ModemManager that is connecting to the bootloader and sending commands to figure out if it is a modem, which interferes with normal use of the bootloader. Can you try running sudo systemctl stop ModemManager and see if that resolves the error? If so, you can run sudo systemctl disable ModemManager to permanently disable that program.

By the way, Debian has an avrdude package, so you can install it by simply running:

sudo apt install avrdude

–David

Right on spot. I’m working on x230 laptop with 3g modem. After stooping that service all works as intended.

Hmmm. I’m pretty sure I have searched repos for avrdude. Must have had typo.

Thanks David…