Problem with power

That’s what happens when power is applied. Maybe it’s because I run the maestro through usb? If so, how do I change the UART mode?

I tried to connect my beaglebone black with the maestro on UART. I used UART1 (P9-24,P9-26). Also i used a logic level shifter, which converted 3,3v to 5v . In Pololu Maestro Control Center i choose: “UART, fixed baud rate”. But maestro did not found :frowning:

It sounds like you are powering the Maestro from USB, which should be fine as long as the servos are being powered appropriately (e.g. from a separate power supply). How are you powering the servos? Can you try disconnecting all of the servos except for one and see if that works as expected? If it does, could you try slowing adding more servos?

It is not entirely clear how you expect the servos to behave. How are you controlling the servos? Are they being controlled from a script or sequence of some kind? If so, can you post your Maestro settings file? You can find the “Save settings file…” option within the “File” drop-down menu of the Maestro Control Center while the Maestro is connected.

As far as the BeagleBone Black, you should be able to control the Maestro with the TTL serial interface through the RX and TX pins of the Maestro (with a logic level shifter like you mentioned). However, I am not sure what you mean when you say that the Maestro was not found; are you trying to control the Maestro from the Maestro Control Center on the BeagleBone Black? If so, please note that it is not supported in that way. Also, you would not need the logic level shifters if you are controlling the Maestro over USB (e.g. TTL serial through a virtual COM port or native USB).


I hooked the servos up with a separate external power supply.
This is a source of power supply(5v, 30A) (Fig 1).

I use mg996r which consumes 1A-2,5A (Fig 2).

If I turn all the servos off, the one does the same way. At this stage, I do not control servos, I just apply power from an external source.
Servos are moving each time of the electrical current supply (this can be seen in the video). I press “on” and they twitch for 1 time. This happens every time I click “on”. Note, please, that this “twitch” does not return them to their zero position, they just deviate from a current state.

As for the Beaglebone Black, I control servos using python. When the servos are connected via USB, everything’s fine (ie Maestro is determined). If I change the circuit from USB (/ dev / ttyACMO) to UART (/ dev / ttyO1) - yellow led is flashing , and the servos are not controlled.

It sounds like there are multiple things going on in your system that you are still trying to figure out. I recommend starting slowly and troubleshooting them one at a time.

It makes sense to start with making sure your servos are working properly. If your Maestro is not currently sending any signals to the servos, it is likely that the startup jitter/jerk you are seeing is inherent to the servos you are using. If you are concerned about the servos all ending up in odd positions, you could use the “On startup or error” setting for each channel in the “Channel Settings” tab of the Maestro Control Center to set each servo to a desired position on startup. To make sure your servos are working properly, could you try removing the BeagleBone and logic level converter from your system and controlling the Maestro from a PC running the Maestro Control Center? You should be able to enable the servos one by one through the “Status” tab and make sure you can turn each one of them.


Yeee, you are absolutely right about servo. The reason that they are “twitch” in themselves. Your advice helped me : “If you are concerned about the servos all ending up in odd positions, you could use the” On startup or error “setting for each channel in the” Channel Settings "tab of the Maestro Control Center to set each servo to a desired position on startup ". Thank you!
I also happened to control servos by UART. However, I am concerned that when the code is running , the red lamp lights up (attach video 1).

If I connect to the maestro usb (but management is still carried out on the UART), the movement becomes soft, and no errors occur (attach video №2).

Help me to understand what the problem is, please. Do I need to remove the jumper maybe?:confused:

Since you are using 5V to power the Maestro (which is the minimum operating voltage), and the problem looks like it happens right as the servos move, I suspect the servos are causing the voltage to dip slightly, and causing problems with the Maestro. You might try removing the VSRV = VIN jumper and applying power to the logic side of the Maestro from a separate 5V-16V supply.


Спасибо чувак!

1 Like