Problem with Micro Dual Serial Motor Controller


I received some days ago my first Pololu order, with a Micro Dual Serial Motor Controller.
I’m trying to use it in the simplest way I could find: using a PC with RealTerm.
So I prepared on a breadboard the circuit suggested in DSMC datasheet, but I can’t make it work… I checked all the connections with a multimeter and they are ok, but when I send commands nothing happens. Should I see the LEDs flashing? Or some echoes in my terminal?
Could it be broken?

Hello, the Micro DSMC is a great little controller, but has no LED’s, so you shouldn’t see anything happening except for your motors turning.

Looking for hardware bugs first, could you describe your wiring connections to the nine pins of the uDSMC? There are a couple of things (like leaving the reset line low) that are easy to miss and will keep your controller from working.

Also, you said you are connecting the uDSMC to a computer, how exactly are you doing that? The uDSMC needs a TTL logic level serial signal (0V-5V), not the higher voltage RS-232 serial signal that comes straight out of your PC’s serial port (which can damage the controller!). Are you using some sort of voltage level shifting device or circuit?

If you want to take a look, there is a discussion of wiring and microcontroller code for the uDSMC here.


Thanks for your reply!

I’m using a 6V NiMh battery pack. I connected + to PIN1, - to PIN2. On my breadboard I set up a simple 5V regulator (using a 7805), powered by my battery pack and its output is connected to PIN3. PIN4 is connected to my PC (see below), while PIN5 is connected, through a 4.7Kohm resistor, to PIN3 (Vcc).
PIN8 and PIN9 are connected to my motor.

About PC connection, at first I simply use the circuit at page 3 of DSMC datasheet (two resistors and a transistor). Then I used a MAX232 (with the reference circuit). If I connect it to a Microchip PIC which simply echoes each character it receives, I can see it in RealTerm so I think the serial part is working.

Isn’t there a way (debug command…) to receive an answer from DSMC?


The motor controller has no outputs besides the motors, so there is no serial debug capability. What are your serial settings, and what are you trying to send?

- Jan


I tried several commands, like:


My serial settings are 9600 baud, 8N1.

Sorry you’re having trouble, but it sounds like you’re doing everything right, so I’m grasping here…

Your serial strings look fine, and of course you’re sending them as their actual bit values rather than as ASCII characters (using the “Send Numbers” button, rather than the “Send ASCII” button in real term).

My only other thought would be that, to get characters echoed back from your PIC you must have connected the PIC’s TX pin to one of the MAX232’s TTL level inputs. Are you sure that Pin4 of your uDSMC is connected to the correct TTL level output pins of the MAX232 IC?


Solved! Today I was to my local store, which is a reseller of Pololu products. I brought with me my breadboard and I was able to test it with another DSMC: it worked fine! So we realize the unit I had was broken and it was changed.

Glad to hear it! What/Where is this local store you can walk into and buy a Pololu motor controller!?!



It’s a quite little store here in Italy… but it carries robotics products and has a good selection of Pololu products.