Problem using Eclipse in Ubuntu

Hello everyone.

I have used eclipse to write my own code to the wixel and it has worked very well in windows. However, i need to get it working in Linux too (i use ubuntu).

I downloaded the eclipse for linux 32-bit and I have followed each step in the tutorial https://www.pololu.com/docs/0J46/10.c. When i try to compile it at the step 9, i get an error message (please, see the screenshot I sent).

I googled it and i didn’t get anything helpful to solve my problem. I really need some help with it.

Thank you!!


Hello.

It would be nice to segregate the errors caused by Eclipse. Could you open a Terminal window, go to the wixel-sdk directory, and just type “make”? You should get that command working before you try to use Eclipse. Also, what version of SDCC are you using and where did you get it? Please see the SDCC version requirement on this page:

pololu.github.io/wixel-sdk/

–David

it does work now!

thank you so much!!

:smiley:

Actually, it didn’t work completely. When i type make I get this message in terminal:

/bin/sh: 1: sdas8051: not found
make: *** [libraries/src/wixel/delay.rel] Error 127

I don’t know what to do right now. Could you help?

What version of SDCC are you using and where did you get it? Also, could you run the following three commands and post their output here?

sdcc -v echo $PATH locate sdas8051

–David

The output is

rafael@rafael-HP-Pavilion-dm1-Notebook-PC:~$ sdcc -v
SDCC : mcs51/gbz80/z80/avr/ds390/pic16/pic14/TININative/xa51/ds400/hc08 2.9.0 #5416 (Feb  3 2010) (UNIX)
rafael@rafael-HP-Pavilion-dm1-Notebook-PC:~$ echo $PATH
/usr/local/bin:/usr/bin:/bin:/usr/games
rafael@rafael-HP-Pavilion-dm1-Notebook-PC:~$ locate sdas8051
rafael@rafael-HP-Pavilion-dm1-Notebook-PC:~$

the last command returns nothing.

I get this version of sdcc just typing sudo apt-get install sdcc

You will need SDCC 3.0.0 or later. Try downloading the source of the latest version from SDCC’s website and the compiling and installing it that way. --David

Thaanks! The make is now working.

But I still get the same three errors compiling at the eclipse.

Anyone can help me with these errors?

I tried to reproduce your problem here using x86 + Ubuntu 12.04 + Eclipse 3.7.2 + SDCC 3.3.0-rc3 but I was unable to. For me, Eclipse highlights a syntax error in xpage.c if I open the file, but it does not report it in the Problems tab and it doesn’t do anything unless the file is open.

However, I have an idea for how to fix it. The code in xpage.c contains a lot of SDCC-specific directives and will not be recognized by Eclipse. We just have to tell Eclipse not to parse it. Please try replacing the code in xpage.c with this:

#ifndef __CDT_PARSER__ __sfr __at (0x93) _XPAGE; #endif

–David