Problem transmitting data between wixels [solved]

Hi this is my first time using wixels.

I have an arduino MicroPro from sparkfun. Its a 3.3v unit.
It is outputting a serial stream via the Tx/Rx communication pins.
I have a pc receiving the data for use in processing.

I am now trying to get rid of the USB cable and make this wireless.

I purchased a set of wixels

installed the console
got the Wireless serial app
loaded it onto wixel #1 with a Serial mode:1 (USB to Radio)
loaded it onto wixel #2 with a Serial mode:2 (UART to Radio)
left all the other setting alone (both wixels on ch 128)

I connected wixel#1 via the usb cable to the pc

I connected wixel#2 to my arduino with:
Vcc from arduino to Vin on wixel
GND on arduino to GND on wixel
Tx on arduino to P1_7 RX on wixel
Rx on arduino to P1_6 TX on wixel

My program did not work so I tried a serial monitor to read the com port being used by the wixel on the pc end

It was set to 9600 baud but It spit out data garbage only…

Any ideas what I could be doing wrong or any thing to try???
I did hook a FTDI usb dongle to my computer and pluged the arduinos Tx and Rx to it instead of the wixels and when I looked at the data in the serial monitor it looked good so the arduino seems to be outputting correctly… hope you can help


I can’t tell from what you posted so far, but something simple that might be cause the data received from the Arduino to look like garbage would be if the baud rates set in the Wixel Configuration Utility for Wixel #2 and the Arduino’s script do not match. Have you double checked that both are set to 9600 baud?


Just resolved it trying while trying to log data to post in this thread.
looks like I was overloading the buffer.
I increased the delay to delay(50) after the println lines in the arduino sketch and the garbage data started looking great…

suddenly this is the coolest little device ever!!!

Asside from the delay issue at my end this is the easiest serial communication ive ever achieved!!!

I was trying to do it with Bluetooth and it was a nightmare… wixel…plug and play!!!