Problem recognizing Mini Maestro "Not connected"


I bought a mini maestro 12, to one of my new robot project, but i just can´t get any of my computers to recognize it.

I guess i must be doing something wrong, but now i give up and need some help.

I have tried it with three different laptops and three different USB-cords.

Other USB-devices works just fine with these computers.

OS:s i have tried with all three computers so far are:

  • Windows XP
  • Ubuntu
  • Windows 7
    All these have been tried with clean installs.

All with the same results.

I install the OS, then i install the driver and plug in the Mini maestro.
First it blinks birefely yellow and after that all leds are off.

A few times i have gotten it to blink yellow, but nothing new shows up under USB or Ports.

First i thought that my hardware might be bad so i bought another Mini Maestro but i still get the same resluts.

I need some tips on how to go further.

Please help!

Kind regards

Hello, Tom.

Has your first Mini Maestro ever worked before? Can connect the Maestro into your Windows 7 computer, and then post a screenshot of your Device Manager with the “Ports (COM & LPT)” and “Pololu USB Devices” entries expanded?

- Amanda

No, none of them have ever worked before.

I will post a picture this evening when i get home, but nothing changes under Device Manager when i plug it in.

Screenshot after clean install, install of pololu driver and plugin usb device.

Thank you for the screenshot. I suspect that your USB cable might be causing the issue since nothing changes in the Device Manager when connecting the Maestro board to your computer. We have seen the same problem when other people try to connect their Maestros to their computers using power only USB cables (e.g. cell phone charging cables) instead of USB cables with data lines. You said you tried three different USB cables and that they work with other USB devices. What are those devices? Are those devices capable of sending and receiving data?

- Amanda

Hi! I’m not sure what I have used the cables i’very tried so far for. I know that I have an USB-cable between my raspberry pi mediacenter, and the media disk. Tonight I will try that cable.
Com&lpt doesn’t show up under device manager after clean win 7 install and install of pololu driver. Is that a problem?

Many thanks for the reply! :slight_smile:
Kind regards

Yes, yes yes!


Now, my laptop detects my Mini Maestro!! :slight_smile:

The USB-cable was the problem. The other USB-devices i had tested did not use this kind of cable.

Now both my Mini Maestros show up.

I had no idea, that there were USB-cables for charging only…

1000 thanks and hugs! :slight_smile:


I am glad that the problem has been resolved; thank you for letting us know.

By the way, to answer your question in your previous post, it is normal for “Ports (COM & LPT)” to not show when no external devices are detected; since your computer did not detect either of your Maestros (or any other USB serial devices), it is not a problem for “Ports (COM & LPT)” to not show up in your Device Manager.

- Amanda