Problem programming tiny84 with pololu usb avr prog and atmel studio 7

(in transition from arduino to bare metal avr)
I am trying to burn a led blink short program into attiny84 using pololu usb avr programmer
In atmel studio I created a target of type stk500 with pololu USB avr programmer programming port (COM9)
Then in Device programming I choose stk500, attny84, ISP and apply button.
Then read target voltage shows 3,vv and I see ISP clock gauge at 115,2kHZ. when I try to read signature I see:

Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xc0, expected 0x00 (Command has failed to execute on the tool)

Unable to enter programming mode. Verify device selection, interface settings, target power, security bit, and connections to the target device.

If I open config app I see Erro from last Programming like: (is read dev signature considered programming operation?)

“Target VDD either went too low or had too much range, so programming was aborted. Make sure that the target is powered on and its batteries are not too low (if applicable).”

uC is beeing powered using a ftdi board, using 3.3v
Pololu red led is statically red
I tested the setup in a brand new uC and in a uC with arduino bootloader. Same result…


Hello, Imo.

We have two different USB AVR Programmers: the AVR USB Programmer and the AVR USB Programmer v2. Just to clarify, are you using version 1 of our AVR USB Programmer?

I suspect you did not change the Target VDD Monitor settings in the AVR Programmer Configuration Utility. By default, the minimum VDD allowed is 4.38 V. You can read more about that feature under the “Configuring the Programmer” section of the Pololu USB AVR Programmer User’s Guide.

If changing the minimum VDD value does not fix the issue, please post a screenshot of the configuration utility after it fails to program your board and pictures showing how you have everything connected in your setup, particularly the FTDI board you are using to supply power to your ATtiny microcontroller.

- Amanda

My fault! I changed minimum allowed and it works like a charm now

Thanks a lot Amanda for the help provided