Problem downloading code to 3pi

I was able to successfully load a test program into the 3pi a couple of days ago, but when I try it today it won’t work. I loaded the demo program into AVR Studio and it builds without errors, but when I try to download it I get the following errors - This happens if I have the 3pi powered up or not. I have shut everything down, unplugged the AVR Programmer, restarted AVR Studio and plugged the programmer back in. Still the same results.

The error messages are not very helpful. I do not understand the meaning of the “debug platform module has not been created”. At one point, I had turned on debugging for another project. Is there some global state that needs to be reset and if so, how is it done.

The file that it is trying to load exists – see below -

I am also having another problem when I try to connect to the AVR programmer. It is connected and I have one green light on and a flashing red light - I am not in debugging mode. I have restarted AVR Studio multiple times and I get the same problem.

Any help would be appreciated.


Problem solved.

I’m having the same problem with the blinking red light. Could you tell me what you did to fix that particular problem?

I’m not sure exactly what problem you are having. A flashing red light means that the programmer’s digital reading of its target VDD line is low, indicating that your target device is probably not powered. The target device needs to be powered for you to program it, so you should turn on the power switch before attempting to program. A solid red light means that you attempted to program, and something went wrong, and the error message from the last programming attempt can be seen in if you run the USB AVR Programmer Configuration Utility. Does that help?


Thanks for your help David. I was misunderstanding something but I’ve got it now