Problem compiling Wixel-SDK apps in Linux (SOLVED)

Hi all,

I am running into an error while trying to compile the standard Wixel-SDK apps in linux (Debian 6.0.3, SDCC 2.9.0). I have the wixel software installed and have no problem running wixelconfig/wixelcmd or loading precompiled apps to my wixel.

I downloaded the latest version of Wixel-SDK. When I run make I get the following error when creating usb_cdc_acm.lib or more specifically compiling usb_cdc_acm.c,

Compiling apps/example_blink_led/example_blink_led.rel
Compiling libraries/src/radio_com/radio_com.rel
Creating libraries/lib/radio_com.lib
Compiling libraries/src/radio_link/radio_link.rel
Creating libraries/lib/radio_link.lib
Compiling libraries/src/radio_mac/radio_mac.rel
Creating libraries/lib/radio_mac.lib
Compiling libraries/src/radio_registers/radio_registers.rel
Creating libraries/lib/radio_registers.lib
Compiling libraries/src/random/random.rel
Compiling libraries/src/random/random_from_adc.rel
Compiling libraries/src/random/random_from_sernum.rel
Creating libraries/lib/random.lib
cp libraries/src/uart/core/uart.c libraries/src/uart/uart0.c
Compiling libraries/src/uart/uart0.rel
cp libraries/src/uart/core/uart.c libraries/src/uart/uart1.c
Compiling libraries/src/uart/uart1.rel
Creating libraries/lib/uart.lib
Compiling libraries/src/usb/green_led.rel
Compiling libraries/src/usb/usb.rel
Creating libraries/lib/usb.lib
Compiling libraries/src/usb_cdc_acm/usb_cdc_acm.rel

libraries/src/usb_cdc_acm/usb_cdc_acm.c:128: syntax error: token -> 'USB_DESCRIPTOR_CONFIGURATION' ; column 39
make: *** [libraries/src/usb_cdc_acm/usb_cdc_acm.rel] Error 1

All of the other libraries (radio_com.lib, uart.lib, etc.) seem to be created without problems.

To investiage further I also tried compiling usb_cdc_asm.c individually in its directory and got the same error.

sdcc -c --verbose -I ../../include/   usb_cdc_acm.c

sdcc: Calling preprocessor...
sdcc: Generating code...
usb_cdc_acm.c:128: syntax error: token -> 'USB_DESCRIPTOR_CONFIGURATION' ; column 39

Any help would be appreciated.


Hello. There were some big changes between SDCC 2 and SDCC 3. Please try upgrading to SDCC 3.0.0 or later.


Thanks David,

That solved the problem. I’m a big fan of the Wixel, great work. Looking forward to seeing the apps and community grow.