Powering A Uno from Zumo Shield - how - solved

Built up one of these cool little Zumo robots and loaded some simple code to it. (Zumo Robot, Zumo Shield, and Arduino Uno.) Had it running around on the desktop after uploading the program and decided to let it ‘roam free’ a bit.

Unplugged the USB cable and, nothing. Stopped dead.

I ‘assumed’ that the Shield would power the Arduino. Is this not correct?

Is there some special jumpering or other wiring required to make this happen?


Yes, if you’re using the Zumo chassis, the 4xAA batteries provide power to the shield, which powers both the motors and the Arduino.

When you insert the batteries and switch the power to ON, the 4 LEDs on the rear corners of the shield will light up. Go back and re-read the assembly instructions looking for something you may have missed.

Hello, Jim.

There are a few things that could be going on. One is that maybe your batteries are just drained. Can you try it with new or freshly charged batteries? Also, can you verify that the Arduino’s 5V regulator is functioning properly? For example, if you disconnect the Arduino from the Zumo and USB, does it run properly when powered through VIN?

- Ben


LED’s come on, motors run under control of Arduino, seems like all is well.


Batteries are fresh, voltage good, no significant sag on motor run. I’ll put together a test fixture to run the Uno from header feeds of power later today (away from the lab and the external power supply right now).

It appears to me (boy, I am really a newbee at this point) that the program resides in FLASH in the Arduino and executes on any power up. Will try power through the header and the power plug and confirm the regulator output.

Thanks !



Tested the Arduino Uno (separated from the shield) with power in on the Vin and Ground pin of the header. Worked as expected.

Checked the Zumo Shield for power on the Vin pin and found none.

Removed the shield from the chassis and (BLUSH) found I had not soldered that connection. (Missed 1 pin. It’s been years since I missed a connection.)

Now works as expected. Got it running around on the floor - this is going to be SO COOL. Now to write some more intelligent code.

(Eeek, can’t even blame a cold joint)

Thanks !


I’m glad you were able to track down the problem; good troubleshooting! Thanks for letting us know what was wrong and that it’s resolved.

- Ben