Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Possible prob with install of Pololu libs


#1

I’ve recently installed the compatibility files suggested on the A-Star328PB users guide.

When I go back to a Nano board and try to upload an app I’ve been working on for MONTHS - I get a verbose error - here is part of it:
…avrdude\6.3.0-arduino9/etc/avrdude.conf": No such file

I tracked this down, and the IS of course all the stuff, but NOT in the now missing ETC folder. In the "…6…3.0-arduino-9 folder are only TWO folders: bin and lib. No etc as the path the uploader is trying to use.

Whats up? I’m dead in the water…


#2

More info on this. It seems the environmental variables have NO mention of avrdude!

Here is an edited-for-readability of the current env vars:

C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q2-update\bin;

C:\Users\AVR\AppData\Local\Programs\Python\Python36\Scripts;

C:\Users\AVR\AppData\Local\Programs\Python\Python36;

C:\Users\AVR\AppData\Local\Microsoft\WindowsApps;

F:\Apps\Microsoft VS Code\bin;

pyb;%USERPROFILE%\AppData\Local\Microsoft\WindowsApps;

F:\Misc\JRE;


#3

SOLVED! - it appears the system environmental variables got messed up. In this path which AVRDUDE uses:

C:\Users\AVR\AppData\Local\arduino15\packages\arduino\tools\avrdude\6.3.0-arduino9\ETC\

The /etc folder was missing! How it got gone I have no idea - but the last major change was to add the pololu *328PB additional path. Perhaps you could take a look at your install scripts. juss sayin’…

Problem solved by simply creating a “etc” folder and placing a copy of ‘avrdude.config’ taken from this folder in the IDE 1.8.5 install:

F:\Apps\ARD\arduino-1.8.5\hardware\arduino\avr\bootloaders\gemma\avrdude.conf


#4

Hi.

I am glad you were able to fix your issue. We are not sure what happened. Did you install the add-on using the Arduino Boards Manager by following the instructions in the guide? We tested the install process again here and were not able to reproduce your problem. The add-on does not contain any installation scripts and is just a set of files that the Arduino IDE should put in the correct location (which is not in that AVRDUDE folder).

If you are able to reproduce the issue or find out more about what happened, please let us know.

-Claire