Polulo USB AVR Programmer Not working!

HI all! I recently bought Polulo AVR ISP Programmer to program my Atmel board ATA6870-DK10. Which is programmed via ISP Programmer. I am using Atmel studio 7 for development. However I am unable to program my board after doing many tries. I also have upgraded the firmware of Polulo ISP programmer to the latest one But still no success.

My Microcontroller on board is Atmega32HVB. Atmel studio is giving me this error. I need to know why to resolve this issue. Kindly help me out here I will be thankful.

Also note that:

Also The Atmel ATmega32HVB supports operating voltage from
4V to 24V.


I am sorry you are having trouble programming your AVR with our programmer. Can you tell me more about your setup? Have you been able to program that microcontroller previously? What is the target board’s voltage? What ISP frequency are you using? Did you set the fuses? Could you describe how everything is hooked up, including the programmer, the AVR, and the clock/crystal?

By the way, we have two USB AVR programmers; which one are you using?


This is the first time I am programming my Atmega32hvb.
This is the one i am using:

i tried freuencies 52Khz and 115.2KHz.
I didnt use any fuse. I dont even know what that is but read it somewhere.
Target board voltage is 4-24V(acceptable). The polulo AVR programmer ISP is connected to the ISP connector of ATA6870-DK10 Board. But I am not able to Run the code using Atmel studio 7. I think issue might be in powering the board as the MCU itself isnt getting enough supply. But can i still program my Atmega32hvb using this programmer?

So Finally I got the signature of the board from AS7 device programming. What I did was I Changed the lower voltage limit of the programmer from its configuration exe file which was located in the bin folder of Polulo AVR Programmer and then lowered ISP clock to 52Khz and got the signature of the device at 3.1V. and from the Fuses section of device Programming I Programmed and verified it and everything was alright. But If I close device Programming. and then Rerun it from AS7 it again gave me the previous Error

ERROR: Failed to enter programming mode. ispEnterProgMode: Error status received: Got 0xc0, expected 0x00 (Command has failed to execute on the tool)

I think it has something to do with Fuses of AS and I am not really aware of it. It might be relevant to saving the configurations that i did.

I need suggestions for this Error. Many thanks


I think I resolved it too. I was changing ISP clock in device programming only but now I have changed it in the Application of AS and it worked

I am glad you can program your AVR now; thanks for letting us know what the issue was.



can i use this programmer to debug my code in the atmel studio?

I have tried it but its not handling break points in the Atmel studio whenever I go for debugging.
What is the best possible solution for this?
Actually i wanted to observe some variables while the code is running on the atmel studio


You can use our programmer with the Atmel Studio to upload firmware to supported microcontrollers, but there is no support for using it as a debugging tool. You might consider running your program in the Atmel Studio Simulator or getting a debugging tool.


I have the same problem. In the past I programmed my 3pi many times but now I just cannot connect to the device. I freshly installed the AS7. I read the discussion but I couldn’t solved the problem and honestly I don’t have too much understanding in the AVR programming. I tried to set different ISP frequency.
In a previous comment I saw a solution can be to change the ISP clock in the application. Where can I find this setting in AS?
“I think I resolved it too. I was changing ISP clock in device programming only but now I have changed it in the Application of AS and it worked”

Thank you for your help!

I found the problem… It’s the LCD screen… I don’t know why when I disconnect I can download the program. Maybe I will try with a new one.