Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Wixel LINUX


#1

Good day,

I have not too much electronics experience. After executing ./wixelconfig I have cascade of errors:

[0625/123311.265012:ERROR:nss_util.cc(94)] Failed to create /home/zdenek/.pki/nssdb directory.
[2294:2294:0625/123313.901230:ERROR:desktop_window_tree_host_x11.cc(1148)] Not implemented reached in virtual void views::DesktopWindowTreeHostX11::InitModalType(ui::ModalType)
[0625/123407.955005:ERROR:nss_util.cc(94)] Failed to create /home/zdenek/.pki/nssdb directory.

I will be very happy to have any adia what I am doing wrong or what I forget.
Thank you. Zdenek


#2

Hello, Zdenek.

I tried to reproduce this issue by running the Wixel software for x86_64 Linux on an Ubuntu 16.04.2 virtual machine and it seemed to work fine. What type of machine are you running the software on? What distribution of Linux are you using? Do these errors actually prevent you from using the software? Do you see a window open when you run ./wixelconfig? If there are more errors visible, please post all of them.

–David


#3

Thank you, but everything start be OK. I have some error news in terminal but windows after open it with sudo ./wixelconfig is running fine. I was able to upload app’s and everything running with Arduino without problem.
Just for information. I am using Linux Mint 18.2.
Thank you again
Zdenek


#4

It sounds like you were able to get the Wixel Configuration Utility to work by running it with sudo ./wixelconfig. Thank you for letting us know how you solved the problem.

–David


#5

Hello again,
I have new problem. Download any program to Arduino or any command from computer wixel works fine but if I need respons from sensor like DHT11 (temperature and humidity) or clock I have no respons. Not sure where start looking for problem and solution.
Thank you
Regards
Zdenek


#6

We have a lot of general troubleshooting advice on our Support page that you might find useful. If that does not help, you could post the details of your system and the details of the problem you are seeing, and I might have some suggestions.

–David


#7

Thank you. Problem solved. Only possible data rate in bits per second (baud) for serial data transmission is Serial.begin(115200) this works for my set-up. Arduino UNO, Linux Mint 18.2, Arduino IDE 1.8.3. and Pololu Wixel 2x programmable modules.
Zdenek