Pololu USB AVR Programmer v2.1 not connecting

Hey guys, hoping I can get help on this, I’m really in a time crunch to get some boards programmed before a trade show and I just absolutely cannot get this USB AVR programmer to connect to my computer. Windows 11 pro.

I have tried what seems like everything I can find in the manual and online and in these forums with nothing working. Nothing is added to the Device manager when I plug it in.

I’ve tried:
multiple USB ports
multiple USB cables (some result in the green LED flashing 1 time per second briefly, the other cables result in green and red LED both flashing at the same frequency, longer “ON” duration than with the other cables)

What am I missing? the configuration utility does not recognize it, nothing is added to the device manager when I plug it in. I’ve tried with it connected to my 328P and not connected.

Thank you for any help!

Okay I tried my 30th cable and it connected! But now I’m getting this error:
avrdude: stk500v2_command(): command failed
avrdude: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.

I have tried playing around with different ISP frequencies, no luck yet.


Can you run the Pololu USB AVR Programmmer v2 Configuration Utility and take a screen shot of it while the programmer is connected? What errors does the configuration utility report after you try to program it?

Can you also post some pictures of your physical setup that show the connections between your programmer and the target device?

- Patrick