Pololu USB AVR Programmer Issues


recently I’ve been trying to program my 3pi and baby orangutans using Atmel Studio 6, but every time I try to debug a build I get this message:

I’ve checked the power on my 3pi, the programmer has 5v at its VDD pin, and everything is hooked up correctly (I think).

The programmer was blinking green (normal) before programming, but afterwards it has been blinking yellow or red after I unplug my target device. Is there a way to reset the programmer’s instructions?

I have my programmer configured like so:
Shown in device manager:

I don’t understand why Atmel Studio 6 doesn’t read the programmer??

It’s really ridiculous working so hard to get something so simple to work. It’s like making cereal. What could possibly be wrong?? :imp:

You need a different type of programmer for debug sessions.
atmel.com/microsite/atmel_st … ation.aspx
For an overview see avrfreaks.net/index.php?name … ic&t=38691

Hello, chriswu.

I am sorry you are having trouble programming your 3pi. Thank you for all the screenshots. I suspect that you have an old programmer and have not upgraded it to the latest firmware version (1.07), which is necessary if you want to use it with Atmel Studio 6. More information about that is available in the “Upgrading Firmware” section of the Pololu USB AVR Programmer User’s Guide.

If that does not help, the first screenshot in your post shows a “Details” button that you can click on to get details. Also, after that error message happens, please select View > Output to see more information about the error.

If you want to reset the programmer, then please try closing all programs that might be using the programmer, then disconnect the programmer from everything, and then reconnect it to USB. This is a good thing to try if you ever have trouble connecting to the programmer.

Plenty of things can go wrong because Atmel does not officially support our Pololu USB AVR Programmer. When they make a new version of AVR/Atmel studio, they might make a change that is incompatible with our programmer, requiring us to make a firwmare update. This has happened twice in the past two years.


I did all the steps to upgrade my firmware. I was at the last step, where the Br@yTerminal displayed a “|” and the red led was on. I unplugged the programmer, but ever since no LEDs have been lit on the programmer at all, and it doesn’t even register on my computer. I don’t read any current running through the board either.

Have you tried disconnecting the programmer from everything and then plugging it back in to USB? Have you tried rebooting the computer? If that does not help, it sounds like something went wrong during the firmware upgrade. I am not sure what went wrong, but I am hopeful that if you try it again it will work properly this time. The instructions in the user’s guide say how to force the programmer into bootloader mode in case the computer is unable to recognize it.


I tried all of it. ^
No lights, no registry in the Device Manager, nothing.
I have the creeping suspicion I’ll have to buy another one of these little troublemakers…
Is there any policy allowing a discount/warranty on products? I followed all the instructions to the T, and everything was working exactly as said on the tutorials, only when I unplugged the programmer after receiving indication it was finished upgrading firmware.

Anyways, thanks.

Unfortunately, there is not much else we can do to debug this on the forum. I have emailed you directly.