Pololu USB AVR Programmer fails to install

I just purchased the Pololu USB AVR Programmer and have been trying to start using it under Windows 7 64 bit. I followed the instructions in the guide and downloaded the avr_development_bundle_110624.exe. It all seemed to install without error, but when I plug in the programmer, it shows up as an Unknown device. The green light blinks a few times when its plugged in, but stays off after that. I’ve tried plugging it in different ports for the same result, and I’ve tried rebooting the machine after the installation, just in case.

One of the other topics had a similar problem that was resolved by re-jigging the cable, but I don’t think thats the case here.


Have you tried using the programmer with a different cable? What makes you think that the cable is not the problem?

- Kevin

I was referring to a loose connection in the port itself, which didn’t seem to be the case. But you were right about the cable - when I dug up another one everything worked! Thanks.