Pololu Serial adapter broken


I purchased recently a Pololu 23201a Serial Adapter from Robotshop Europe and it doesn’t seem to be working. Robotshop told me to contact you directly through your forums in order to troubleshoot the device and approving the product for exchange if it is really broken.

I’ll now describe my setup and the test’s I’ve done. I’m providing 5V to the adapter using a 5V voltage regulator attached to a LiPo battery. The voltage regulator is one like this

hobbyking.com/hobbycity/stor … oduct=3735

(which is used on RC aircraft), and I have tried various LiPo batteries. The regulator and batteries are working well and I have measured 5.38V at the output of the voltage regulator.

I have tried a loopback various times test and it hasn’t work. I have also made a loopback test of everything minus the adapter (i.e., shortcutting pins 2 and 3 on the end of the serial cable which i would plug onto the adapter) and it’s working well.

I have also measured voltage on some of the output pins of the adapter. Both the TX (which ought to be high when the serial line is idle) and the INV pin (which ought to be high when the serial cable is connected) show 0.98V instead of the 3-5.5V they should. The INV pin is really 0V when the serial cable is unplugged, so there is really voltage change, but not enough to drive the logic state to high.

I can measure more voltages and try different setups, but I have no fancy equipment (such an oscilloscope) at hand.

Hello, DaniE,

I am sorry to hear you are having trouble with your serial adapter. Could you post some pictures of the setup you are using? How long are the leads from your battery and the regulator?

What did you use to measure the voltage coming from the regulator? I am a little concerned about your measurement of 5.38 V, since that is getting close to the recommended maximum of 5.5 V on VCC.

- Kevin

Yes of course. I have taken some images.

This is the loopback test on the serial cable. I use a female jumper wire to shortcut pins 2 & 3.

greendragon.homelinux.org/~danie … CN4103.JPG

Overview of the whole setup. As you can see, I measure the voltage using a standard multimeter. I always measure on the test pads of the connectors of the jumper wires. This photo shows the battery powering the adapter. The voltage regulator has a 220uF cap across the output and the length of the wires between the output and the adapter is 38 cm (which was the shorter i could get).

Today the voltage measured on VCC was 5.36V. I don’t know how much can we trust the multimeter, since I have nothing to test if the measure is 100% exact.

greendragon.homelinux.org/~danie … CN4104.JPG

This is a measure of the INV pin with the serial cable connected.

greendragon.homelinux.org/~danie … CN4105.JPG
greendragon.homelinux.org/~danie … CN4107.JPG

The voltage on INV is 0.91V with serial cable plugged (should be > 3V) and was 0V with serial cable unplugged.

This is the loopback test on the adapter.

greendragon.homelinux.org/~danie … CN4108.JPG

The voltage on TX with the serial line idle was also 0.91V (should be > 3V).


I do not see any obvious problems with your setup, so if you would like to try again with a new adapter, you can contact us directly to arrange a replacement.

One thing you might want to try changing is to use a lower voltage regulator; although 5.3-5.4 V is supposed to be within the allowable range for the adapter, it is possible that powering it so close to its maximum voltage increases the chance that voltage irregularities could damage the adapter.

- Kevin

Today the new adapter has arrived and it has worked fine. I’ve used the same voltage regulator and battery plus a 330uF cap to protect from LC spikes.

Thanks for your support, Kevin.


I am glad to hear the new adapter is working for you. Thanks for the update.

- Kevin