Pololu Maestro and ASME 04b Servo issue


I am trying to control a large servo with the poulou maestro however i am finding that when i move the slider quickly, the servo cuts out.

If I use an RC controller, or stand alone servo controller. It works fine. It is almost like the signal from the maestro isnt as good as the other sources.

Anyone have suggestions?


To avoid confusion, please note that our company name is spelled Pololu (we have corrected it in the title of your post).

My first thought is that it might be a power issue; could you post details about how you are powering your Maestro and servo?


Sorry about that. So the servo is powered by Lipo Batteries equal to 24v. I am using a LM2596 DC to DC Voltage Regulator 4-40V adjusted to 5.5v to feed the Pololu Maestro.

Is the regulator powered from the same LiPo battery as the servo? You might try monitoring the battery voltage as well as the output voltage of the regulator with an oscilloscope to get a better idea of what is going on. For example, the servo might be drawing enough current to cause the voltage to dip or just creating a lot of noise.

If you don’t have access to an oscilloscope, you might try powering the Maestro from a separate source as the servo (making sure to still have a common ground connection) and see if that improves it at all.


I do, i will take some readings and report back. Thanks

I would not be concerned with the voltage on your servo control board when the RC input is not connected unless you can see some interference it is causing on your oscilloscope (it sounds like it probably just has a pull-up resistor on it internally).

As you alluded to in your latest video, it seems like the joints you are having problems with have significantly more load than the others. Additionally, in your first video, it seemed to only struggle when it was lifting the arm up (i.e. moving against gravity). So, that leads me to think that it is a problem with the mechanical setup or servo. However, if this was the case, I would expect it to have similar behavior when you try your other RC source. Is there still a significant difference when using the Maestro to generate the signals compared to your other board? Could you post an updated video showing the improved behavior how that you have the ground wire connected? Could you try adjusting the settings on your oscilloscope to get a cleaner, close-up capture of the Maestro signal? Also, could you try connecting the Maestro to the Maestro Control Center and see if it is indicating any errors or if anything look unusual?

Lastly, could you post some more information about the servo system you’re using such as a datasheet as well as a copy of your Maestro settings file? You can save a copy of your settings file from the “File” drop-down menu of the Maestro Control Center while the controller is connected.


I wanted to get back to this thread so to not leave you hanging. I noticed my batteries where down to 3%. After charging them up and fixing the grounding issue. It seems the issue is solved at least for now. I did however encounter another issue where the maestro output shuts off when i slide the slider back and forth from one extreme to another. It only occurs with one of the large servos and tosses a serial port error. When i have time I will record and post that on a new thread. I was hoping the low battery would fix that but it seems at least this orginal issue is solved for now.

I’m glad to hear the main issue has been resolved! For the new issue, it sounds like the Maestro is probably browning out and resetting, so I suspect your power supply voltage is dipping too low when the servo moves rapidly or changes direction quickly due to the excess current draw. I suggest trying to same test I recommended before and monitoring the battery voltage as well as the output voltage of the regulator with an oscilloscope when you move your large servo in the manner that normally causes the problem.