Pololu item# 1132 Unstable

I am trying to use several Pololu item 1132 as a simple proximity switches. The led on the carrier flashes at power up and continues to flash until a reflective surface is placed within approx. 100mm in front of the sensor. When this reflective surface is detected the led on the carrier turns off and stays off until the reflective surface is moved to within 50mm or the sensor, then the led turns back on. I have placed a 22uf capacitor from vcc to gnd to smooth out Vcc but it did not make any difference in the behavior. While the led on the sensor is flashing, the device that is being switched by Vo is being turned on and off. The device being switched is operating at ttl signal levels. Any suggestions?


How are you powering your sensors, how long are the power leads, and where is your cap in the system? How many sensors are you using simultaneously? Could you post a picture of your setup?

- Ben

Power is from a switched 5vdc wall wart supply. Cap was placed at the 3 pin connector on the carrier board. The wire length from the supply to the sensor is about 50cm. I plan on testing using a 6 volt battery to eliminate Vcc noise issues and test with one sensor only. Is the flashing of the carrier led ever a normal condition?

The LED is directly connected to the output, and the output should only be low when the sensor is detecting an object, so flashing is not normal behavior.

Please keep in mind that the maximum operating voltage for the sensor is 6.2 V, and batteries can be significantly above their nominal voltages when new/fully charged. Separately, please make sure you have an electrolytic capacitor across VIN and GND near the board if your supply voltage is near the maximum limit to suppress any LC voltage spikes.

Please let me know how it works with a different power supply.

- Ben

A more robust power supply with a very clean output was tried with no change.
The device that I am trying to switch is a an ELETECH EM3038A-X which has TTL logic inputs When one of these inputs is pulled low an mp3 file to be played. The EM3038A-X inputs are described as having 10k ohm resistors to pull them up to 5vdc. When I connect Vo from the 1132 sensor to one of these inputs and the ground to ground (no Vcc connection yet) the voltage of the input goes from 5 volts to a little under 2vdc. When I apply 5vdc to Vcc the voltage at Vo swings from near 0vdc to near 5vdc until a reflective surface is brought within the measurement range. So I am wondering if the the fundamental problem is using cmos logic levels to switch a ttl device. Suggestions?

Making logic connections to an unpowered device is generally a bad idea.

Using just the LED for feedback (or a multimeter), can you tell me how the sensor behaves with only power connected (i.e. disconnect Vo)?

- Ben

It is as it should be, at Vcc until reflective surface is in the detection range, then essentially zero. Looks like I need some sort of solid state relay or equivalent. If you have a suggestion I would appreciate it, if not, thanks for your help.

You could probably just connect your EM3038A-X input to ground through a MOSFET controlled by the reflectance sensor output.

- Ben

I used a non inverting hex buffer NTE4050B to buffer the output of the 1132. This did not change the behavior of the device. I decided to reduce the Vcc to 3 volts, the device worked fine when connecting the leads from the carrier board directly to the battery pack. When I connected to the battery using some 24 inch clip leads, the led started flickering again and the device was unstable. I tested again with a 6 volt battery, I got the same result, working with carrier leads only, but not when using clip leads. So my previous testing that indicated the need for a buffer was not necessarily true after all. It seems very odd to me that this device could be so affected by lead length. Any idea how I can fix this? Thanks.

The sensor draws current in large, short bursts; it sounds like it just cannot get enough current for these bursts when you are using the longer leads. The capacitor should solve this problem. Can you verify that your capacitor is connected properly (i.e. to VIN and GND with the correct polarity) and well soldered? Can you try a larger capacitor?

- Ben

I soldered a 1000uf 16v cap Vcc to gnd (+ to + and - to -) about a 10mm from the 3 prong plug that attaches to the carrier board. Looks like the problem is solved. Thanks for your help.

Glad to hear it’s working, though 1000 uF sounds a little excessive. I’m willing to bet that 50 uF would have been enough, or maybe 100 uF at most.

- Ben