Pololu ISP programmer stopped working after windows update

I was using the programmer I bought fine nearly every day. It’s a brilliant product and I love the size of it. However, stupid Windows 7 made me install updates and restart. I postponed restarting by 4 hours about 10 times and then finally thought I would restart when I watched TV because it was annoying me so much.

Anyway, after restarting this is what I get from avrdude:

I tried re-installing the pololu drivers and restarting again, but it still has the same problem. The green light is on, my board is connected, and there is a blinking yellow light because my board has power. Although, I get exactly the same error if I unplug the 6-pin ISP cable from the board entirely.

How can I fix this?


I am sorry you are having problems with your AVR programmer. It looks like there is a typo in your command-line argument. The programmer protocol should be avrispv2; you have avrisp v2 (with an extra space). Can you try the command-line instruction again using avrispv2?

- Amanda

Ah yes thank you that worked!! It must have been where the command line was broken to the next line - I saved it to a text file before restarting. Do you know if there is any way to deploy code from atmel studio using this device? Or that software is for atmel official programmers only?

I am glad you got it working again. You can follow the tutorial under the “Programming AVRs Using Atmel Studio 6” section in the AVR programmer user’s guide to learn how to set up your system to program AVRs using Atmel Studio and your programmer.

- Amanda