Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Pololu avrdude write eeprom timeout

Hi I recently bought the pololu usb avr programmer v2.1.

I used to use an arduino uno with an avrisp from sparkfun in, which still never misses a beat, although its a lot slower.

I can succesfully program my pcb with the pololu and verify it.

However I am experiencing trouble when I try to use the -t flag.

avrdude -P COM13 -b 19200 -c avrispv2 -p m1284p -t

I get the following response as I would expect.

avrdude: AVR Device initialized and ready to accept instructions
Reading|##### | 100%
avrdude: Device signature = 0x1e9705
avrdude>

when I try to execute the command

write eeprom 0 0x70 0x01 0x02 0x03 0x04 0x05

it just hangs and then I get timeouts
avrdude: stk500_2_ReceiveMessage(): timeout
avrdude: stk500_2_cmd(): short reply, len = 0

Is this a known problem? or do I need to configure the device differently in the configuration tool.

If I execute the same command with the arduino uno programmer interface it works fine.

Thanks.

Hello.

Unfortunately, AVRDUDE’s -t option is not compatible with the programmer because the programmer will exit programming mode and release the target AVR from reset if it receives no programming commands for 1500 ms. This is a safety feature to prevent the AVR from being held in programming mode for an extended period of time, where it is susceptible to corruption by bad signals. Does your application require interactive programming?

-Patrick

Hi Patrick,

At the moment we need interactive programming as we use the write eeprom to put our mac addresses into the device.

As a suggestion, could you not offer the timeout as a configurable option in the pololu app to allow custom timeouts or a 0 for never timeout?

Cheers

Craig

Hi Patrick,

Once I knew it auto timed out after 1500ms I decided to look to a different route.

… I did some googling and worked it out…

avrdude -P COM15 -b 19200 -c avrispv2 -p m1284p -U eeprom:w:“0x70 0x01 0x02 0x03 0x04 0x05”:m

Which worked great I like as i get a verify feedback now that the memory programmed correctly.

Cheers

Craig

2 Likes