Pololu AVR Programmer & ATMEGA2560 Issue

I’m running a Windows 10 system along with a new Pololu USB AVR Programmer (1.7 Firmware) I just got. This is my first time using one of these so please bear with me. I installed the Windows suite and driver. Everything was detected and is in Device Manager correctly. The Pololu AVR configuration utility sees the programmer and the version of software it’s running. I also installed Atmel Studio 7.0 and configured the Programmer COM port per the instructions on this web site.

The problem I’m having is that the green LED is solid on, but the red LED on the USB AVR Programmer is blinking. I’ve got it plugged into my Arduino clone (Seeeduino 2560 ADK) ATMEGA2560 ADK with pin 1 on the programmer to pin 1 on the ICSP header. The voltage on my 2560 is set to 5V. I know the 2560 is working since I’ve programmed and used it frequently. I’ve reset the programmer and 2560, turned them on in different orders, configured the correct COM port (programmer device) in Arduino IDE, uploaded the ICSP sketch to the 2560, tried different ISP frequencies, etc.

No matter what I do I can’t figure out how to get the AVR Programmer to see my 2560. I’d appreciate any ideas!


How are you powering your Seeeduino board? Can you run the AVR Programmer Configuration Utility after a failed programming attempt using the one of the IDEs (let us know which IDE you used) and post a screenshot of the utility window here? (The utility comes with the drivers during the installation and can be run from the Start menu. You can find more information about the utility in the USB AVR Programmer User’s Guide.)

- Amanda

Thank you for the reply! I’m powering the Pololu via my laptop’s USB port and my 2560 from a USB wall-wart plugged into household power (cell phone charger). Both devices power up and seem like they’re operational. If I unplug the AVR programmer and plug the 2560 directly into my PC, I can program it no problem so that’s working. I’ve attached a screen shot of what the configuration utility looks like. Also, I haven’t tried actually programming through the AVR programmer yet since the red light was flashing.

Without attempting to program your Seeeduino, the “Error From Last Programming” section of the configuration utility does not provide any meaningful details on what could be causing the issue. Please try programming your Seeeduino from Atmel Studio, run the configuration utility, and post a screenshot of it here.

- Amanda

Thank you, but it just started working out of the blue. I didn’t do or change anything. I’m thinking maybe the 6-pin cable is flaky. Thank you for your help.