Pololu 3pi not showing up in Arduino boards manager

Pololu 3pi robot does not show up in boards manager. the example libraries do show up in the library manager. the pololu library is saved in C:\Users\phoen\Documents\Arduino\hardware. I updated the drivers in device manger and checked the com port. Any suggestions would be appreciated thanks.


Just to clarify, could you clarify which version of the 3pi robot you’re using (i.e. the original 3pi, the 3pi+ 32U4, the 3pi+ 32U4 OLEDor the 3pi+ 2040)?

Could you post more information about your setup such as what version of the Arduino IDE and what operating system are you using? Also, could you post a screenshot of your C:\Users\phoen\Documents\Arduino\hardware directory and your Device Manager?


Yes of course, it’s the original 3pi, Arduino 2.2.1, windows 11

com ports


Can you confirm that you are following the instructions in the “Configuring the Arduino Environment” section of the Programming Orangutans and the 3pi Robot from the Arduino Environment guide?

Also, please make sure you are checking for the 3pi robot in the Board menu, which is under Tools (and not the Boards Manager). I just tested the procedure here on a Windows 10 computer with Arduino 2.2.1, and the menu gives these results:

- Patrick

This is all that shows up in my boards manager under the tools section. I have tried following the guide you suggested. This is the exact problem I am having where the board does not appear as shown in the image attached.

Can you post screenshots that show the following:

  • the title bar of the main Arduino window
  • the window that opens when you select “Help” and then “About the Arduino IDE”
  • the Preferences screen (from selecting “File” then “Preferences…”)

- Patrick

Title bar of main Arduino window:

About Arduino IDE:

Preferences screen:

Everything seems to be what I expected and the same as my setup, so it seems like your libpololu-arduino might somehow be missing something. The only file we expect Arduino 2.2.1 needs to see to make those boards menu entries should be here:


Can you confirm that file exists and post a copy of it here so we can confirm that it looks correct?

Also, just in case you have not done so already, could you try restarting the Arduino IDE?

- Patrick

Yes I’ve tried restarting the arduino IDE. here is the boards.txt file shown in the correct folder:

Can you post a copy of the “boards.txt” file here on the forum?

- Patrick