Pololu 36v4 no analog speed control

Hi, I have a problem controlling stepper motors using the 36v4 on “analog speed” control mode.

The power supply is a bench type capable of delivering 10 amps, and set to 12 volts. The motor is a Shinano Kensi STP-42D1037, 1.8degr/step 1,7V 0.8A.
I configured the analog pot joystick using the “learn” feature, and it is picking up the right settings.

It will go into this mode with resume command, displaying the right values of the pot in the main window, the motor is powered but no movement at all responding to the joy stick. The weird thing is, the yellow led on the board does respond with its appropriate blinking status.

But even weirder, when I put the board into “analog position” mode, it WILL respond to the movements of the joystick.

I checked with an oscilloscope on the STEP pin if any output is measured in “analog speed” mode but no joy…

I also reflashed the device with version 1.08 but that unfortunately did not help either.

Here are the screenshots of the software:

Could somebody bring some light into this matter?


To avoid confusion, please note that our company name is Pololu (not “Polulu,” which was originally in your title).

I suspect it is working as intended but your speed is set so slow that you cannot see it moving. It looks like you have the Target Minimum and Target Maximum set to -200 and 200 respectively; for reference, in analog speed control mode the units for the target are pulses (microsteps) per 10,000 seconds, which means your maximum target is currently set to only 0.02 pulses per second.

As mentioned in the “Setting up analog speed control” section of the Tic user’s guide, we recommend following the instructions in the “Configuring and testing the stepper motor” section first. The “Setting the movement parameters” heading of these instructions cover how to find the maximum achievable speed, so once you set that, you can use that value (or smaller) to set your limits for the analog speed control.


Hi Brandon,

Thanks for the rapid response.

I feel so stupid not spelling your company name correct. In my mind it always was polulu instead of Pololu.

I must have misinterpreted the manual section, it wasn’t obvious at the time. It’s working now, with the correct speed values.

So for these simple but stupid mistakes i apologize…

Greetings, Danny

1 Like

I’m glad you were able to get it working as expected! Thank you for letting us know.

By the way, the Pololu/Polulu mix-up is something we see all the time; Pololu is named after Pololu Valley (on the north coast of the Big Island of Hawaii). If you’re interested, you can find more information about our company name in the About Pololu section of our website.

Good luck on your project!