Pololu 23201a Serial Adapter not functioning with loopback

I bought the Pololu 23201a Serial Adapter to fix my bricked Seagate 7200.11 Hard Drive a while ago. I’ve been using this guide to fixing the HD.


The part I got stuck on was the loopback test with the RX and TX pins. I haven’t connected the Hard Drive yet, so anything relating to that can’t be it. HyperTerminal didn’t recieve any messages when I typed (typing did nothing), but when I unattached and reattached the TX and RX pins while the adapter was running, I saw weird symbols appearing on the HyperTerminal screen. At first I thought it was a faulty serial cable, but I got the same results when I connected the adapter directly into the computer. I also tested this on another computer just to be sure the serial plug wasn’t faulty, same results with the weird symbols.

Is something wrong with the Adapter, or is it something else?


How are you powering the serial adapter?

- Ben

It’s powered from a separate computer with a power supply. I plugged the male jumpers into the VCC + GND of the adapter.

Are you sure made the connection to the proper power rail? If you accidentally connected power backwards or used something other than the 5V rail, it would probably destroy the adapter. Can you measure the voltage across VCC and GND using a multimeter?

- Ben

I don’t have a multimeter in my house to measure with, but I know for sure I never hooked up the adapter with the yellow cord on the molex (+12V). One of the sections in the guide said this… and I made sure not to touch the yellow cord after reading it.

An important note here - the (typically) yellow wire on one side of your molex connector is +12V and should not be wired to anything on your setup other than the pre-wired SATA power connector for the drive. That much voltage is needed to eventually spin your drive motors but will almost certainly fry things in the adapter setup we’re making here. Frying is great for three-cheese frittatas and sole meuniere but not for computer components. - mapleleafmountain.com/seagatebrick.html

I think making assumptions about voltages is asking for trouble. Is there anything other than color that leads you to believe you are connecting 5V to VCC? When working with electronics like this, having a multimeter around can be extremely handy, and I definitely think it’s worth the $20 investment.

Have you tried doing a simple loopback test on the serial port itself?

- Ben

Well, again, I was using a guide that’s been confirmed to work. I did have a friend over that helped me while I was trying to fix the Hard Drive though.

The other end of those male jumpers you just plugged in need to connect to the red and black wires on the power adapter’s small four-pin connector, the one intended to power a fan as described in the parts list. Insert the loose ends of the male jumper wires into the corresponding holes on the power adapter, one to a red wire (voltage) and one to a black wire (ground). Remember too that you can extend most of your jumper wire lengths by mixing and matching the male and female ends of more wires as needed.

There were actually, 2 black wires on the molex. The guide above didn’t mention which one, and my friend said it didn’t matter. Perhaps it did matter and I killed the adapter when I hooked it up to the wrong black wire?

I apologize for not searching before, but I didn’t expect anyone to have my EXACT problem. Anyway, I found this post after searching for “seagate” in the search box.

Looks like more than one person is having this problem. I’m not blaming the adapter though.

I haven’t tried doing a loopback test on the serial port itself, how would I do that?

P.S. I can feel heat on the Serial Adapter.

What I’m worried about is that your particular power supply somehow differs from the assumptions made by the document you are following. We have had a few people complain of malfunctioning adapters in the context of trying to follow that seagate guide, which makes me concerned that something about the guide’s instructions can lead to trouble for people with setups that differ in some way from the guide’s writer. We test every unit before it ships, and since all you’ve connected so far is power, it makes me wonder if that power connection was correct.

To perform a loopback test on the port, take the adapter out of the picture and connect the port’s transmit pin directly to its receive pin. Feeling heat from the adapter is not a good sign.

- Ben

I tried looping the serial directly. I don’t get any messages on HyperTerminal. Is anything else required other than connecting the RX and TX with a male jumper?

So the heat is bad? My friend said the warmth from the adapter mean it was on. BTW, why does HyperTerminal recieve weird symbols when unattaching and reattacing RX and TX on the adapter?

Warmth usually a sign that an appreciable amount of current is flowing somewhere, but it really depends on how “warm” it’s getting.

The only connection you need to make is from your serial port’s transmit pin to the receive pin. Are you sure you’re shorting the correct two pins together (which two pins are you connecting?)? Are you trying it at the end of a serial cable or on the computer directly? If that’s not working, then your problem could just be with the way you’re trying to use the port (i.e. hyperterm is not configured correctly), or with the port itself.

Connecting and disconnecting the adapter probably introduces electrical noise that gets interpreted by your computer as a random serial character. This makes it sound like you do have Hyperterm connected to the correct port and the serial receive line is working.

- Ben

I’m connecting pins 2 and 3 in the above picture. The 4 pins is below the 5 pins, so I know I’m not accidently connecting 3 and 4. I’m connecting it directly to the port (without serial cable).

My friend (yes he’s real, I know a lot of people say “My Friend” when they mean themselves), said the problem could have been the serial cable was the wrong type. Do you by any chance know what type it has to be? He took the cable with him when he left to try and figure out what type it was.

P.S. A bit off topic, but I’m looking through the rest of the site, and I just got myself hooked onto the 3pi (It’s so fast!). I need to have it for Christmas. (Great Job with the Demo Video by the way) :smiley:

I’m familiar with two different types of serial cables: a normal cable and a null modem cable. The normal cable just passes the pins straight through, so that the pins on the one end of the cable exactly match the pins on the other. A null modem cable swaps the RX and TX lines within the cable and is used to connect two RS-232 devices in a way that lets them talk directly to each other (since the RX of one connects to the TX of the other and vice versa). You want to use a normal cable with our serial adapter, not a null modem cable. It doesn’t matter which cable you have if you just want to do a loopback test on your serial port, however.

Without some more advanced diagnostic tools, such as an oscilloscope, I’m not sure what else to suggest. There’s little point in bringing the 23201a adapter back into the picture until you get the loopback test for your bare port working. Do you have any other RS-232 devices you can try connecting to your serial port or any other computers with serial ports you can test?

I’m glad to hear you’re excited about the 3pi! Thank you for the compliment on the video. And don’t worry, I believe that your friend is real :slight_smile:

- Ben

Sorry for not replying for a while. I wanted to wait for the DB9 serial cable to arrive to test the loopback.


I can’t seem to even get the loopback working on just the serial cable. I have the RX and TX connected through a new premium jumper wire (from pololu), yet HyperTerminal doesn’t seem to be responding. Any ideas?

Here’s some pictures of my setup.

General Overview

More General Overview

Jumper Cables, Breadboard, and Adapter

Molex, Power

Serial Cable Plugged In

Serial Port (Original image was too dark, brightened in GIMP)

Is this right? :stuck_out_tongue:

P.S. I don’t have any other RS-232 devices to check, sorry.

Nevermind, I got the serial cable to loop back!!! :smiley:

My problem was that the metal parts of the jumper cable were touching the metal part of the serial extension. Once I lifted them a bit, it worked perfectly :0

I’m going to try it with the adapter now.

Edit: Shoot, my adapters smoking!!! O_O

Well, I unplugged the adapter from the breadboard, since I wanted to see if the breadboard was faulty (20 years old). I connected the VCC and GND ports manually onto the adapter. After a while, I smelled something smoking, bent closer to the adapter, and found that it was the adapter.

I plugged the adapter back into the breadboard and tried again. Nothing. Unplugged it, and connected the power directly again. The adapter starting becomming hot again.

If I killed the adapter (I know for sure I didn’t connect the yellow wire), would it become warm again afterward?


At the point where you’ve had smoke coming out of electronics, it’s very unlikely to work again. It’s completely possible for it to get warm again.

- Jan

Well, it’s not exactly smoking. It was just hot enough for me to smell it. I know for sure I hooked up the adapter with the right cords though.

I’ll try and get a multi-meter and measure the voltage level.

I am also having a similar problem.

I have loop checked through the cable, and through the initial connections on the adapter’s board, but the pins do not return a positive check. I have tried using 5.02V and 3.38V (both confirmed with a voltmeter) on the VCC pin and read the same voltages on the opposite side of the board where the pins pass through. The adapter is cool and there is no visible damage to the board. I have also connected everything with and without a breadboard with the same results.

Any help is appreciated! thanks.



What is your power supply and how long are your power leads? Can you post a picture of your setup?

- Ben