PGM03A Dead


I just bought the USB AVR Programmer, installed the drivers on Windows Server 2008 flashed my ATTiny45 a couple of times in AVR Studio 4 / WinAVR.

I plugged in the programmer to flash the chip again and the USB interface registered the Bootloader mode instead of the programmer mode. I unplugged the programmer and re-plugged it, but it still came up in bootloader mode. I then re-plugged the device and got no response from the computer at all.

After reading the forums, I shorted the bootloader pins and re-plugged the programmer again. It came up in bootloader mode, so I fired up putty and flashed the firmware (v1.01) according to the instructions. After getting the pipe symbol back, I waited 5 seconds before unplugging the programmer.
Plugging it back in then worked, so I fired up AVR Studio, hit “Connect”, selected “AVRISP” with port “auto”. When I attempted to read the device signature, the programmer disappeared and went back into bootloader mode.

Now, when I plug it in, I get no response from the computer. Shorting the bootloader pins briefly registers two devices:

Neither of the devices stay connected long enough for me to see them in Device Manager. Finally, the bootloader / power LED blinks steadily.

I’m completely out of ideas here.


The Pololu USB AVR Programmer only goes in to bootloader mode if it receives the right USB command from the computer (which is unlikely in your case) or if the processor gets reset while the bootloader pad / green LED line is at 5 V. So I am wondering if there is something causing the programmer to get reset.

What did you have connected to the programmer when the strange behavior you described was happening? Was your AVR connected the whole time? How was AVR powered? What else was your AVR connected to?

I suggest disconnecting everything from the programmer and then just plugging it in to USB and trying to get the computer to recognize it properly again.

Also, Windows Server 2008 is not one of the operating systems we support for the programmer, so it is possible (but unlikely) that something about the OS is causing your problems. Have you tried it on a different computer?


Hi David,

I’ll try to address your questions in order:
Q: What did you have connected to the programmer when the strange behavior you described was happening?
A: It was connected to an ATTiny45V and an LED. The LED was connected across AVR pins 5 and 3 with a 150ohm current limiting resistor. The code generates a PWM signal that quickly ramps the LED up and down to simulate a firefly flash.

Q: Was your AVR connected the whole time?
A: When the odd behavior started, the AVR was connected. When I ran into problems, I disconnected the cable from the programmer and performed all further testing with the programmer disconnected from everything but the USB cable.

Q: How was AVR powered?
A: It was powered by 5v from my variable bench power supply. I set the current limiter on the bench supply to 500mA to prevent runaway in case of a short.

Q: Have you tried it on a different computer?
A: I have since tried it on a WinXP SP3 system as well as a Win7 system. Server 2008 is built on the same core as Vista and uses the same drivers. My Win2K8-x64 system is my primary development box since I also do .NET development for that platform.

As an aside, I am not new to electrical design, soldering, software development or Windows hardware / software interfaces. I am new to the AVR chips, but I have had a PIC programmer for years.

Thanks for the detailed answers. One last thing I suggest is that you try using a different USB cable, but that’s not likely to solve the problem.

There’s not much more I can determine about the programmer without seeing it. Please contact us directly for an RMA number so you can mail it back to us. Be sure to include enough information so that we can find your order in our database. If you are unable to test the programmer using another USB cable, then you should send the USB cable back to us along with the programmer.


Hi David,

I have tried with a different USB cable, and have also used the supplied USB cable on some of my other USB devices. The cable appears to be fine. I called in and received an RMA number and will be shipping the programmer back for repair or replacement very soon.

I’m looking forward to getting back to flashing my AVRs as I have a few other projects that I hope the AVRs will be able to help out in. I especially like the Slo-Scope function of the programmer and I hope to be able to extend the software to support storage and replay of data.

Thanks for all your help.

Hello, pbarrette.

I received your returned programmer yesterday. I was able to reproduce the problems you were having, but I do not know exactly what caused them. When I reflashed your programmer’s bootloader and firmware, everything worked fine, so maybe the flash got corrupted somehow. We’ll send you a new programmer. Someone will call you to confirm your shipping address.