PGM02A issue, and Windows

Ok, I received a PGM02A for Xmas, and just now finally have time to look at it (it’s amazing how little free time you have when you have your first kid!).

I’ve followed the driver installation instructions on multiple machines, and each time Windows detects a USB device, says “USB Device not recognized”, and puts it in as ‘Unknown USB device’. It does this with the Pololu drivers, or the SI Labs CP210x driver set.

When looking at the device from device manager, I get this for a device ID:

Device Instance ID: USB\VID_0000&PID_0000\5&269A58E2&0&9

Tried removing/reinstalling the drivers, and tried this on multiple PCs. Tried the jumper both in programming, and serial modes, no change.

Is there something fundamental I’m doing wrong?


Ken Matlock


I’m sorry to hear about your problem with the programmer. I’m not sure when the device ID gets filled in, but the zeros for VID and PID don’t look good. If you’ve tried on several computers and are sure you followed the directions, there’s not much more we can do for troubleshooting. You can contact us directly with your order details to get an RMA number to send the unit back to us.

- Jan