Orangutan USB Programmer - Firmware Update

Hi guys,
I’m new around here, so please bear with me…

I received today my 3Pi robot together with the USB programmer…Ole ! I’m using the Arduino environment to program it, and I was quite happy for a few hours, except the fact that after each time a program would dowload to the the robot (successfully), somehow the link between the programmer and the PC would hang… I would have to disconnect the usb cable and connect it back every single time…

So I decided to update the firmware… Everything works well

  • connect the programmer to the usb cable
  • quickly type ok in “Tera Term”
  • quickly type FWBOOTLOAD (which displays “1.3”)

So everything works up to here… Now I type “s”, the 2 RX/TX leds turn on for a few seconds (erasing the old firmware I guess) and then NOTHING!!! I’ve been waiting for the “S” echo for minutes, retried everything, and the same result…
I’ve also tried to continue with the “Send file” option, but the RX/TX leds turn off, and no echo whatsoever appears on the screen…

Therefore, right now the programmer has no firmware on it and it’s completely useless… Imagine how frustrating, not to be able to program you robot the very first day you receive it !!! snif…;(

Any help would be more than welcome…

Added Apr5th:
Also, when I try to update the programmer software version (pololu.com/docs/0J6/5.c) it simply doesn’t work: I try typing “config” but nothing is echoed back. I tried this while connecting to the programmer in both firmware update mode (during the first 5 seconds after power on) or in “normal” mode (connect to it after the 5 secs)…

Please help ! it’s getting so frustrating…;(


P.S. before you guys ask:

  • yes the jumper on the programmer is in the “P” position
  • the programmer is connected to the 3Pi robot, which is turned on (otherwise, the RX/TX leds keep flickering, they don’t light up continuously for the 5 announced seconds, and it’s impossible to type that FWBOOTLOAD command…

Ok guys, can anybody help or suggest anything ?

It really seems it’s the BOOTLOADER on the programmer that has a problem… To recapitulate:

  • I can connect with a terminal

  • I can type fwbootload (and I do get back “FWBOOTLOAD 1.3:”)

  • THEN

  • if I type “s” the leds flicker (as if it does delete the supposedly existing firmware - right now I think it’s completely empty) but NO “S” echoed back. Also, if I keep trying to binary transfer the new 1.4 firmware, nothing happends, no acknoledgment, and the leds are OFF.
    So basically, once I type “s” the programmer deletes the firmware and then SHUTS down it’s connection…

  • HOWEVER if I type “x” instead of “s” (at the “FWBOOTLOAD 1.3:” prompt) , I do get the echo (“X”) back…

I’d like to konow if I’m missing something obvious before I start calling the Pololu client service to send it back…

Many thanks for any help!

For others interested in this topic, Dan has contacted us and is sending the programmer back for us to test.

- Jan


So finally, last night, while preparing the package to send back the programmer to Pololu (thank you guys, you’re really quick and friendly on the phone !) I told myself, let’s give it another try, all this doesn’t really make sense.
And guess what: it worked from the first try ! I could connect as usual to the boot loader, and then when typed “s” the “S” came back as echo… I then sent the binary file with the 1.4 firmware and everything works fine now…

So, sorry everybody for loosing your time, I swear I had tested everything on Sunday: disconnected the programmer completely, try with it connected to the robot or not, with the robot on or off, etc … Virtually every single combination possible…

Now that I think of it, the only thing that has changed, might be the fact that the PC had been restarted between Sunday and Monday evening… So maybe it was a problem with the USB-Serial driver or the serial Terminal…

Anyhow, I’m a “happy man” again now…:slight_smile:

That’s great! Thanks for letting us know.

- Jan

Greetings everybody.

I know that this is a very old topic but I have a problem that quiet similar to Dan.

I suppose I have succesfully updated the firmware from 1.3 to 1.4. I know it succesful because I got exactly like what you’ve said in the user guide:
“You should also see the red status LED below the reset button flickering as the firmware update progresses. When the upload is complete, the programmer will transmit *SUCCESS to indicate success.”

Then I repeat the steps to check the current firmware. It echoed 1.3 where I think it suppose to be 1.4.

I tried again couple of times, but still it echoed 1.3. Is there anything wrong here?


I suspect what you’re seeing is the bootloader version, not the firmware version. When you follow the procedure for updating the firmware, the number that appears after you type “fwbootload” is the bootloader version. From the user’s guide:

You can check your firmware version by following the steps in section 5.c of the user’s guide. The terminal screen that shows the firmware version number will look something like this:

Please let me know if you still see “FW:1.3” when you follow the steps in section 5.c.

- Ben