Orangutan SVP-1284 - Failed to open COM

Hi to all

Hope you can help with my problem, I followed all the avr programming quick star guide, installed the AtmelStudio 6.1, also installed the pololu AVR development bundle, then created a new project from the installed templates, build the solution and no errors, but when trying to program by pressing F5 I have this error

"Atmel Studio was unable to start your debug session.
Please verify device selection, interface settings, target power and connections to the target device.

Timestamp: 2013-07-23 22:26:31.984
Severity: ERROR
ComponentId: 20100
StatusCode: 1
ModuleName: TCF (TCF command: Tool:connect failed.)

Failed to open COM17. Error 0x2."

I already tried changing the COM port number but have the same issue

i’ll appreciate your help!!!


Hi to all

I found in some other post here that AtmelStudio 6.1 “don’t like” COM ports beyond COM9 so I’ll change the COM ports to a number lower than 9, I’ll let you know the result.



I am sorry you are having trouble connecting to your Orangutan SVP. Can you try restarting your computer and checking to make sure that Atmel Studio’s target serial port is connected to the correct one? The SVP makes 3 different COM ports - and Atmel Studio should be connected to the one labeled “Programming Port”. Also, what operating system are you using?

There used to be a bug in Atmel Studio where it was unable to open port COM10 or higher because it was using the wrong name to open it. That often created the same error code. This should be fixed in the current version of Atmel Studio, so I do not expect information from that other forum post to help.



I’m running Windows 7 and I just changed the COM1 COM2 and COM3 respectively for the 3 COM ports that Orangutan created. Still getting the same error (but now with COM1):

18:25:00: [ERROR] Failed to open COM1. Error 0x2., ModuleName: TCF (TCF command: Tool:connect failed.)

The Controller firmware is 1.03 and 6xAA 220mAh batteries fully charged
Any idea what is causing this error?

Thanks for your help.

Hi Jon

I just reinstalled the Firmware to the orangutan and it worked, still don’t understand why this happend but thanks for your help!!!
:smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley: :smiley:

here is a small video showing the orangutan with the sample code provided on the guide:

thanks :wink:

Thanks for letting us know it works!