Orangutan SVP 1284 A0-A7 pins stopped working


I was using my Orangutan SVP 1284 for over a year and everything seemed to work corectlly, However, yesterday, when I tried to connect my Sharp analog distance sensor to ports A0-A7, it wasn’t working properly. For example, I connected it to pin A0, made program to read value from that pin (under 10bit conversion) and i started the program- afer startup the value was around 390 and it rapidly lowered to 240, after there was no change, regardless the reading of the sensor. I assumed that the sensor is malfunctioning, so I meassured its output with external voltmeter: it was fine.To eliminate possibility of program error, I decided to try svp-demo-program from examples folder of pololu library, and make it show analog values. Trimpot readings were correct, analog pins readings A-D on second processor were correct, but when i connected my sensor to A0-A7 pin, the value of all 0-7 channels was changing in the same time ( I mean, the sensor was connected to A0, but values of all channels were changing to the same numbers). I tried to compile the program from 2 different computers, with USB programmer and also external ISP programmer and i got the same result. Any ideas? (BTW I tried more then one sensor- i got the same result)


I am sorry you are having trouble with your SVP. However, I think your SVP is probably OK because the behavior of the SVP demo program that you describe sounds normal. By default, the demo program lets all the analog input lines float, so the voltage isn’t guaranteed to be any particular value. I think you can hit the top button on the SVP to turn on the internal pull-up resistors on those lines; then they should be high by default.

If you want help getting your program to work, could you post the simplest possible version of your code that should work but doesn’t? Also, please tell us what the expected behavior of the program is and what the actual behavior is. The exercise of simplifying your code will probably reveal what was wrong with it.


Hello David,

thank you for your fast response. I found a small thing in program that made all the trouble. Sorry that I bothered you. Everything is working fine now.
Btw, I would like to congatulate you and whole Pololu for your great job- your products are taking hobby robotics to a new level. Keep up! You are just amazing :slight_smile: