Orangutan setup problems...not recognized on USB

I just bought a Orangutan X2 Robot Controller. I’m using xp. I installed the drivers following these directions:

I got the “Installation Successful" message. When I plug the Orangutan into my computers usb port I get nothing.
Any thoughts on what I should do?

Hello, Dave.

I’m sorry you are having trouble.

Do you see any LEDs on the Orangutan X2 turn on when it is plugged into USB? Do you see any entries for it appear in your Device Manager? Do you have a different USB cable you could try, and a different port?



I am having the same problem with my X2. I ‘successfully’ install the software, but I cannot get either Windows XP or Windows 7 (I realize it’s not officially supported) to recognize the device.

I have tried different USB ports and a different cable, but nothing seems to work. The X2 board has lights indicating it has power, and it has been placed in programming mode.

Windows will make a sound when I plug in the USB cable, but throw up a message from the task bar saying the device was not successfully installed.

Just for some additional info, the preloaded demo program does run – I am just having trouble getting the OS to recognize the programmer.


No LEDs light up. Nothing in the Device Manager. I’ve tried multiple cable on multiple usb ports on two machines. I’ve used the device manager to search for new hardware and adjusted the USB port power management to keep power to ports. Still nothing.

Mine may be working now. I was playing around with the demo program while the usb was plugged into my computer and the computer detected it.

Hello, rizard2012.

Let’s focus on getting the Orangutan X2 to work on your Windows XP computer first. Do you see any entries for it appear in your Device Manager when you plug it in?


No, there are no entries in the device manager.

Hello. Sorry for the delay in getting back to you. You said that Windows was giving you messages about the device, so are you sure there are no entries? Could you check the “Other Devices” category (if it exists) and tell me all the entries you see there?


Sorry for the late reply!

There is no “other” category, but there is an unrecognized device under the USB category.


Could you click on that Unrecognized Device and tell me what the Hardware Ids are? They are found in the details tab.

Does that Unrecognized Device go away when you unplug the Orangutan X2?